+ Responder Tópico
  1. #1
    Suspenso
    Info
    Registro
    Dec 2002
    Mensagens
    8.668
    Verdinhas
    1

    Performance no MAME ( Cruis´n)

    Ae o Cruis´n USA e o Cruis´n World do MAME roda muito lento aqui, tem jeito de melhora isso ou é o emu q num tem suporte decente ao jogo ainda?

  2. # Publicidade
    Publicidade

  3. #2
    Membro
    Info
    Registro
    Feb 2003
    Mensagens
    1.938
    Verdinhas
    0

    Isso deu uma discussão danada há um tempo atrás...

    Usa a procura que vc deve achar, os caras começaram a brigar por causa disso

  4. #3
    Suspenso
    Autor do tópico
    Info
    Registro
    Dec 2002
    Mensagens
    8.668
    Verdinhas
    1

    Originalmente enviada por ¯`·._.·´¯`·._.
    Isso deu uma discussão danada há um tempo atrás...

    Usa a procura que vc deve achar, os caras começaram a brigar por causa disso
    Desculap ae mas eu já tentei procura, já tinha visto um topico sobre isso tb, mas qd fui procura agora num achei...a busca do forum num encontra resultado!!!!

  5. #4
    Membro
    Info
    Registro
    Feb 2003
    Mensagens
    1.938
    Verdinhas
    0

    Hm... então não sei mesmo... só me lembro que foi um quebra pau danado que durou vários dias

    Daqui a pouco aparece alguém que lembra do tópico

  6. #5
    Redação
    hardMOB
    Avatar de Rodrigo Guerini
    Info
    Registro
    May 2002
    Mensagens
    12.634
    Blogs
    10
    Verdinhas
    1645

    Adivinha quem lembra do tópico???

    É o seguinte... Ter como rodar o jogo até tem... Mas vai dar um bom trabalho... Primeiro procura direito no procura (procrure por 'MAME' neste fórum que tu deve achar rápido, embora o tópico já é meio antigo).

    De qualquer forma... Tu vai conseguir rodar o jogo por volta de 30 a 40 fps... e na teoria ele fica jogável... Só que, por causa do controle analógico do volante no arcade original a transposição para o teclado NÃO ficou boa... ou seja... acaba ficando INJOGÁVEL por causa disso...

    Vale a pena??? Sinceramente eu acho que não... Anyway, se tu tiver um controle analógico dá uma tentada as vezes aquele mame tem suporte...

    PS: E existe uma versão correta de mame para se tentar, não é a oficial...

  7. #6
    Redação
    hardMOB
    Avatar de Rodrigo Guerini
    Info
    Registro
    May 2002
    Mensagens
    12.634
    Blogs
    10
    Verdinhas
    1645

    Achei o tutorial que o 'DOWNLOAD' fez...

    "Um dia eu estava dando uma lida neste tópico, e resolvi tentar ajudar tentando emular este jogo que é bem legal, o Cruis'n USA. No começo não estava dando certo, mais depois que eu fiz isso, deu pra emular sim, na verdade, deu até pra jogar.

    Tinha tentando de tudo, até que uma vez, eu tirei o som do jogo e sem querer dentro do jogo, apertei a tecla " (aquela do lado do numero 1). Ai vi que aparece um pequeno menu bem abaixo da tela. Nele tem umas configurações que são:

    Overclock CPU1, Overclock CPU0, DSC DAC Volume, Volume, Gamma e Brightness

    Observação: Sem som o menu fica sem as configurações de volume.

    Ai eu comecei a mexer nessas configurações, e vi que o responsável pelo atraso que vinha dando no video era o Overclock CPU 0. Depois eu percebi que o Overclock CPU1 era o responsável pelo som.
    Foi então que eu mudei essas configurações.

    No OverclockCPU0 tava 100%. Eu esperimentei colocar 200%, mais ficou mais lento ainda. Então coloquei 1%, e vi o jogo praticamente para. Foi então que deixei em 20%, e fico bom, digamos, da pra joga, mas não fica "aquilo".

    Dependendo de quanto você deixar, a emulação e os frames podem chegar a 100%. Mas a velocidade do jogo fica um pouco estranha. Por isso deixei em 20%. Assim, os frames e o jogo, rodam numa velocidade melhor. Pelo menos eu acho isso, e também acho que essa porcentagem vai variar de pc para pc.

    Bom, jogando sem som, a emulação ficou variando entre 76% a 100%, que é em média 45 a 59 frames por segundo.

    Depois tentei jogar com o som do game ativado. Também deu pra jogar, mais fico meio estranho, as vezes ficava atrasado, as vezes ficava cortado e tinha vezes que parecia ser um "som espacial".
    Foi então que alterei o Overclock CPU1 para 80%. Mesmo assim o som não fica igual ao real e a emulação fica variando nos 60% e os frames no 35.

    Nesse tópico vocês também falam da tecla F9. A tecla F9 é responsável pelo frame skipping (pulo de quadros).
    O padrão do emulador Mame é dexar-lo em "auto" (Automático). Se você for apertando esta tecla, ele vai mudando de auto para 0, 1, 2...
    Isso também influência na emulação e na quantidade de frames por segundo. No meu caso, eu prefiro deixar-lo no 0, ou no 1.

    Como eu não tenho joystick, ficou muito dificil jogar. =/

    Então povão, agora é só tentar ae que talvez da certo. =D
    Espero ter ajudado e acho que não vai ser necessário postar meu screenshot, afinal espero que todos vocês iram ver seus próprios resultados."

    Acho que as novas versões do mame não possui esse menu, então se quiserem baixar o mame que tem, o endereço é esse:

    http://www.nullsoft.com/free/kaille...64-203-ka09.exe

  8. #7
    Membro
    Info
    Registro
    Jun 2001
    Mensagens
    1.414
    Verdinhas
    37

    Até hj eu nunca consegui emular o Cruis`n USA nem o World aki .Foram os únicos jogos q eu não sei q diabos acontece q a porra do jogo trava na tela pra calibrar a porra do volante sei la ...E nunca ng aki de me deu uma luz pra eu conseguir rodar o jogo...nem sei como eh a 3 fps!hehehe...mas como sei q a emulação dele ainda eh tosca , desisti ...

  9. #8
    Suspenso
    Autor do tópico
    Info
    Registro
    Dec 2002
    Mensagens
    8.668
    Verdinhas
    1

    O controle p/ min naum vai ser problema (eu acho!), tenho um Volante SideWinder. hehheheh

  10. #9
    Redação
    hardMOB
    Avatar de Rodrigo Guerini
    Info
    Registro
    May 2002
    Mensagens
    12.634
    Blogs
    10
    Verdinhas
    1645

    Originalmente enviada por la_de_longe
    O controle p/ min naum vai ser problema (eu acho!), tenho um Volante SideWinder. hehheheh
    Então teste, ehhe.. se tiver algum resultado, favor postar..

  11. #10
    Suspenso
    Autor do tópico
    Info
    Registro
    Dec 2002
    Mensagens
    8.668
    Verdinhas
    1

    Originalmente enviada por Mago_1982
    Então teste, ehhe.. se tiver algum resultado, favor postar..
    Lento do jeito q ta aqui nem c/ volante num presta! Primeiro preciso dexa ele c/ uma velocidade "jogavel".

  12. #11
    Redação
    hardMOB
    Avatar de Rodrigo Guerini
    Info
    Registro
    May 2002
    Mensagens
    12.634
    Blogs
    10
    Verdinhas
    1645

    Originalmente enviada por la_de_longe
    Lento do jeito q ta aqui nem c/ volante num presta! Primeiro preciso dexa ele c/ uma velocidade "jogavel".
    Favor ler respostas grandes para o teu tópico.. thanks!...


    -_-

  13. #12
    Suspenso
    Autor do tópico
    Info
    Registro
    Dec 2002
    Mensagens
    8.668
    Verdinhas
    1

    Originalmente enviada por Mago_1982
    Favor ler respostas grandes para o teu tópico.. thanks!...


    -_-
    Bom, c/ jogando c/ o volante ficou perfeito, mas ainda naum consegui melhorar a velocidade, mesmo desabilitandi o som, naum encontrei o menu q fala no Tutorial (OverclockCpu...etc), mesmo na versão do Mame do link acima, aqui c/ o som tc ' aparece uma barra de volume, e s/ o som aparece uma barra de gama e brightness.

  14. #13
    Redação
    hardMOB
    Avatar de Rodrigo Guerini
    Info
    Registro
    May 2002
    Mensagens
    12.634
    Blogs
    10
    Verdinhas
    1645

    Você precisa usar a versão correta do mame para ter esse menu e poder rodar o cruis....

  15. #14
    Membro
    Info
    Registro
    Jun 2003
    Mensagens
    493
    Verdinhas
    0

    Originalmente enviada por la_de_longe
    Bom, c/ jogando c/ o volante ficou perfeito, mas ainda naum consegui melhorar a velocidade, mesmo desabilitandi o som, naum encontrei o menu q fala no Tutorial (OverclockCpu...etc), mesmo na versão do Mame do link acima, aqui c/ o som tc ' aparece uma barra de volume, e s/ o som aparece uma barra de gama e brightness.
    Então, vc tem pegar o mame que tenha essas opções de overclock. Eu não lembro onde eu peguei ele, mais sei que nesse site tem varias versões de mame
    http://www.mame.net/oldmame.html

    Ps: Eu uso o UO MAME32k 0.64 (Feb 3 2003) , e nesse tem essas opções.

  16. #15
    Suspenso
    Autor do tópico
    Info
    Registro
    Dec 2002
    Mensagens
    8.668
    Verdinhas
    1

    Originalmente enviada por Download
    Então, vc tem pegar o mame que tenha essas opções de overclock. Eu não lembro onde eu peguei ele, mais sei que nesse site tem varias versões de mame
    http://www.mame.net/oldmame.html

    Ps: Eu uso o UO MAME32k 0.64 (Feb 3 2003) , e nesse tem essas opções.
    Bom esse Mame q eu to usando aqui é o mesmo q vc cita lá em cima (Mame32k 0.64) peguei do seu link mas aqui naum aparece menu nenhum a naum ser o de Gamma e Brightness. Vc disse q tem q tirar o som do jogo, eu desabilitei o som do Mame e num funcionou, ainda continua aparecendo só Gamma e Brightness qd aperto a tc '.

+ Responder Tópico Ir para o Fórum

Assuntos do tópico

Compartilhar

Permissões