+ Responder Tópico
  1. #1
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Feb 2001
    Mensagens
    3.839
    Verdinhas
    6

    Direct3D lento vs OpenGL rápido

    Aêw !
    apareceu um problema meio estranho aqui:

    Meu irmão trocou o Athlon classic 700 dele c/ 384MB pc100, Asus K7V e R8500LE por um A64 3k+, 512MB ddr400, e colocou a mesma placa de video, só que agora com bios de 9100 (copiada da minha, que é identica a dele, ambas eram 8500LE).
    Formatamos o hd (só aproveitou hd e video), colocamos o windows, instalamos os drivers novos, etc. só que continuou praticamente a mesma performance, do DOD (mod de HL) antes ficava de 15 a 25 fps, agora fica em 20-30 fps, isso em D3D, em OpenGL fica 99.9, não só o contador, e sim os "lag" de imagem, travadinhas e etc somem, mas em D3D tem tudo, como no pc antigo.
    no 3Dmark'01 meu pc faz 36fps no Nature rodando a 1.3Ghz (memo sdr) e o dele ta fazendo 14fps, testamos o ultimo driver, o mesmo driver que uso aqui e mesma coisa.
    Inicialmente tinha colocado o XP SP2, aí descobri que o driver AGP não era instalado automaticamente, tentei instalar na mão e não adiantou, aí coloquei o primeiro XP (sem SP1) e não adiantou.
    Só nos jogos que tem opção pra rodar em OpenGL fica bom.
    Como resolver isso ?

    config: A64 2.04Ghz, Abit KV8 Pro, 512mb kingston, R9100 250/250 e cooler Polo 735

    valew !

  2. # Publicidade
    Publicidade

  3. #2
    Membro Avatar de V1P3R_BR4Z1L14N
    Info Conteúdo e Citações Jogos Mensageiros
    The cake is a lie
    Registro
    Jul 2004
    Mensagens
    12.303
    Verdinhas
    228

    format no hd dele e instalar o driver agp corretamente, pega o ultimo via hyperion (novo nome do Via 4-in-1) em www.viaarena.com

    PS: jogar dod e ter uma placa de video dessa em um a64 é pecado kra =/

  4. #3
    [email protected] Team Avatar de junecaz
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Oct 2001
    Mensagens
    5.728
    Verdinhas
    167

    Tenta instalar o driver pro agp mesmo por cima, se n funfa formata mesmo.

    jr.;

  5. #4
    Membro
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Feb 2001
    Mensagens
    3.839
    Verdinhas
    6

    ja formatei e o Hyperion diz que não instala o driver AGP no XP SP2 por causa de algum negocio a ver com a M$
    por isso formatei denovo, coloquei o XP "normal" e instalei o Hyperion com o driver AGP mas não adiantou do mesmo jeito.

    ps: ele pegou o pc pra jogar HL2, mas como ainda não achou aqui, ta só no Dod

    edit: acho que não tem mais a ver com o driver agp pq em Opengl os jogos ficam muito rápidos mesmo, por isso esse negocio ta muito estranho

  6. #5
    Membro
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Feb 2001
    Mensagens
    3.839
    Verdinhas
    6

    nem idéia do que pode ser ?

  7. #6
    Membro Avatar de Darktag
    Info Conteúdo e Citações Jogos Mensageiros
    Doe sangue.
    Registro
    Aug 2004
    Mensagens
    12.839
    Verdinhas
    3956

    Esse bios mod foi testado durante a utilização do computador antigo ou só foi testado no novo?

  8. #7
    Membro
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Feb 2001
    Mensagens
    3.839
    Verdinhas
    6

    Originalmente enviada por Darktag
    Esse bios mod foi testado durante a utilização do computador antigo ou só foi testado no novo?
    só no novo.
    e antes de fazer o "mod" tambem no novo, mas continou a mesma coisa.

  9. #8
    Membro Avatar de BIGX333
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Feb 2002
    Mensagens
    6.339
    Verdinhas
    3

    1 - D3D em hl1 eh uma M E R D A

    2 - Vc so testo dod? pq hl1 precisa mais de processador doque placa de video. Ja tento outros jogos? ut 2k4, hl2 qualquer coisa .

  10. #9
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Nov 2003
    Mensagens
    2.828
    Verdinhas
    1

    Originalmente enviada por BIGX333
    1 - D3D em hl1 eh uma M E R D A

    2 - Vc so testo dod? pq hl1 precisa mais de processador doque placa de video. Ja tento outros jogos? ut 2k4, hl2 qualquer coisa .


    Disse tudo...esquece D3d para o hl1.
    Opengl na cabeca para hl1 e todos os seus mods.

  11. #10
    Membro
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Feb 2001
    Mensagens
    3.839
    Verdinhas
    6

    não, "véios".
    todos os jogos/programas em D3d tão uma m*rda e todos em OpenGL tão ótimos !
    Quake3 roda perfeito e RAPIDO com tudo no maximo (aliás, como liga o contador de fps no Q3 ?), já o 3dmark, NFSU, War3 não estão tão bons assim, no normal ja percebe q os fps não tão grande coisa
    eu sei q Q3 é leve, mas War3 tbm é e Q3 fica MUITO mais rapido.

  12. #11
    Banido
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Dec 2001
    Mensagens
    15.625
    Verdinhas
    2

    bota -opengl no final do atalho do warcraft 3 que o problema se resolve por enquanto.

+ Responder Tópico Ir para o Fórum

Assuntos do tópico

Compartilhar

Permissões