+ Responder Tópico
  1. #1
    Membro Avatar de Marc-BR
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jun 2001
    Mensagens
    3.240
    Verdinhas
    57

    Erro No Boot - "unknow Flash Type" (ecs K7sem 1.0) - Nao Atualiza Bios !!!!

    Bom, ja existe um outro topico perguntando a respeito dessa placa mae (ECS K7SEM rev. 1.0) se ela aceita processador "SEMPRON"...

    Focado nisso, eu resolvi atualizar a bios dessa placa mae...
    Entrei no site da ECS dos USA, dai baixei a atualizacao da bios PARA A K7SEM 1.0 e do lado tinha o programinha de atualizacao da bios correspondente... (A BIOS EH AWARD)... Fiz tudo certo... criei um diretorio "C:\BIOS" e pra la joguei o programa de atualizacao para bios AWARD, e o arquivo da bios atualizada que eu baixei...

    Eu peguei um disquete de boot do win98, enfiei no micro e liguei.
    Dai aparece a tela da bios e tal, dai quando COMEÇA O BOOT DO DISQUETE, bem no comecinho, quando começa a leitura do disquete, ja da um erro "UNKNOW FLASH TYPE".... e tal, mas boota o disquete blz.... dai depois de bootar o disquete, eu ja vou pro PROMPT ("A:/>")

    Dai eu vou la, rodo o programinha de atualizar a bios... dai pede pra entrar com o nome do arquivo ( "sem630.bin" ), eu entro com o nome certim... o programa pergunta se eu quero faze um backup da bios atual... salvo como "bkp.bin", dai pergunta se eu quero atualizar.... respondo SIM... dai quando ele vai processa, da um erro: "UNKNOW FLASH TYPE"... e NAO ATUALIZA A BIOS.

    Eu tenho certeza absoluta que o arquivo da bios ta certim(afinal eu baixei compactado e descompactei no diretorio C:\bios , pq se tivesse corrompido nem descompactar iria). E depois, eu ate cheguei a tentar atualizar a bios com o arquivo de backup que o proprio programa gerou e da o mesmo erro: "UNKNOW FLASH TYPE"....

    Ou seja, acho q esse erro q aparece na inicializacao(antes do boot do disquete) tem a ver com esse mesmo erro que aparece quando eu tento atualizar a bios...

    e dentro da bios nao tem nenhuma opção de "CMOS LOCK - enable/disabled" ou "CMOS/BIOS UPDATE - Enabled/Disabled"...
    (algumas bios tem proteção contra atualizacao, mas nesta placa mae naum tem)...

    Alguem sabe o que pode ser??

  2. # Publicidade
    Publicidade

  3. #2
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jul 2001
    Mensagens
    3.695
    Verdinhas
    4

    velho! tu tá colocando a bios errada e deu sorte de não ter atualizado! Velhin leia e pesquise mais a respeito disso! Se você atualizar por uma bios errada já elvis sua placa mãe! Toma cuidado cara!



  4. #3
    Membro Avatar de Marc-BR
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jun 2001
    Mensagens
    3.240
    Verdinhas
    57

    Originalmente enviada por Titôsca
    velho! tu tá colocando a bios errada e deu sorte de não ter atualizado! Velhin leia e pesquise mais a respeito disso! Se você atualizar por uma bios errada já elvis sua placa mãe! Toma cuidado cara!


    cara, vc nem leu o meu topico affff

    eu sei atualizar bios muito bem, nao sou nenhum leigo, faço isso direto....

    pra começo, essa placa mae K7SEM 1.0 q eu to, nunca foi atualizada a bios !! (eu disse nunca)
    Mesmo assim, antes do boot do disquete da esse erro "UNKNOW FLASH TYPE".... antes de dar boot num disquete de boot do win98... a atualizacao eu faço manualmente...
    E eu tenho certeza absoluta que eu baixei a bios certa. Eu baixei pra K7SEM 1.0 (tem essa opção pra download no site da ECS)...

    E pra provar mais ainda que eu nao fiz NADA ERRADO... eu ja cheguei a entrar no programa de atualizacao de bios, gerar um backup da bios atual... dai eu tento atualizar a bios com o backup da bios e TAMBEM DA ESSE ERRO DE "UNKNOW FLASH TYPE".... ou seja, nenhuma versao de bios correta feita pra essa placa mae atualiza... qualquer versao de bios correta da esse erro de unknow flash type...

    *** IMPORTANTE FICAR BEM CLARO:
    essa mensagem de "UNKNOW FLASH TYPE" aparece em 2 momentos DIFERENTES:
    1) antes de dar o boot no disquete(na inicializacao/antes de ler o disquete)-isso acontece sempre, inclusive antes da primeira vez que eu inseri o disquete de boot do win98 pra tentar atualizar a bios
    2) essa mensagem "UNKNOW FLASH TYPE" aparece de novo, na tela do programa de atualizar bios quando eu respondo "YES" pra atualizar a bios... dai aparece essa mensagem de erro e cancela a atualizacao da bios... ou seja, ate hj a bios dessa placa nunca foi atualizada

    ta claro agora?

  5. #4
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Mar 2002
    Mensagens
    2.573
    Verdinhas
    336

    Realmente ele está fazendo tudo certo.

    Unknown Flash Type = Tipo de Flash Desconhecida

    Ou seja, a memória flash (chip do BIOS) não está sendo reconhecida.

    Existem 2 possibilidades:
    - a versão do AwardFlash que você está executando é antiga, e não suporta o chip.
    - o chip está com seu código de identificação danificado.

    Qual a versão que você está utilizando do AwardFlash?
    Procure uma mais recente e tente novamente.

    Ou ainda tente o Uniflash (http://www.uniflash.org).

    []s,
    Daniel

  6. #5
    Membro Avatar de Marc-BR
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jun 2001
    Mensagens
    3.240
    Verdinhas
    57

    Originalmente enviada por braziliantech
    Realmente ele está fazendo tudo certo.

    Unknown Flash Type = Tipo de Flash Desconhecida

    Ou seja, a memória flash (chip do BIOS) não está sendo reconhecida.

    Existem 2 possibilidades:
    - a versão do AwardFlash que você está executando é antiga, e não suporta o chip.
    - o chip está com seu código de identificação danificado.

    Qual a versão que você está utilizando do AwardFlash?
    Procure uma mais recente e tente novamente.

    Ou ainda tente o Uniflash (http://www.uniflash.org).

    []s,
    Daniel
    eh eu cheguei a pensa nessas 2 coisas... Mas esse tal de programa "uniflash" eu naum sabia!

    eu naum lembro direito a versao do programa award pra atualiza bios... eu ACHO que é 4.38b (nao tenho certeza, amanha qd eu tiver no trampo eu confiro)....

    mas eu tenho minhas duvidas pq esse erro de unknow flash nao aparece soh no programa, mas na inicializacao do micro! (antes do boot) e isso me faz pensar q "provavelmente" nao seja a versao do programa de atualizacao da "Award"... Mas, estou torcendo para que seja isso(versao do programa da award) pq se for eh muito facil resolver!
    Agora se o chip estiver danificado ai fudeu !

    Esse tal de "uniflash" atualiza bios award neh?? vou tentar amanha!!
    obrigado

  7. #6
    Membro Avatar de Marc-BR
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jun 2001
    Mensagens
    3.240
    Verdinhas
    57

    A versao do programa da award que eu usei pra tentar atualizar a bios é 8.32B

  8. #7
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Mar 2002
    Mensagens
    2.573
    Verdinhas
    336

    Essa versão que você usou deveria funcionar.

    Tente o Uniflash, mas quase que certeza que o chip está danificado, por causa do erro no boot, no qual o BIOS tenta detectar o chip para gravar DMI.

    Remova o selo sobre o chip e verifique o modelo da flash.
    Em alguns casos, o uniflash permite que você corrija esse tipo de erro (ID inválido) ou force a atualização.

    []s,
    Daniel

  9. #8
    Membro Avatar de Marc-BR
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jun 2001
    Mensagens
    3.240
    Verdinhas
    57

    Originalmente enviada por braziliantech
    Essa versão que você usou deveria funcionar.

    Tente o Uniflash, mas quase que certeza que o chip está danificado, por causa do erro no boot, no qual o BIOS tenta detectar o chip para gravar DMI.

    Remova o selo sobre o chip e verifique o modelo da flash.
    Em alguns casos, o uniflash permite que você corrija esse tipo de erro (ID inválido) ou force a atualização.

    []s,
    Daniel
    cara, eu baixei o programa da award versao windows.

    É o "Award WinFlash versao 1.75"... eu abro o programa, clico na opção do menu VIEW -> BIOS INFORMATION... e la tambem aparece "UNKNOW FLASH TYPE"....
    acho q a minha bios ta danificada mesmo, parcialmente pq o micro ta funcionando ! Sera que nao é meio arriscado tentar forçar uma atualização?

    O Award winflash 1.75 simplesmente nao deixa forçar a atualização... se vc tenta atualizar a bios, ele fala "File size dont match" e naum atualiza...
    com uma versao mais antiga do award winflash (versao 1.51), quando vc tenta atualizar, da esse mesmo erro "file size dont match" e logo em seguida pergunta "are you sure do u want to program?".... ou seja, pela versao 1.51 do winflash tem jeito de forçar a atualizacao, mas eu achei arriscado

  10. #9
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Mar 2002
    Mensagens
    2.573
    Verdinhas
    336

    Veja se o Uniflash consegue detectar o chip!!! Ele suporta mais chips que o AwardFlash. Se ele não detectar, está com problema mesmo.

    Olhe a marca/modelo do chip, retirando o selo sobre ele.

    Dependendo do modelo é "normal" acontecer isso às vezes (perder a ID).

    Mas é meio arriscado sim. O ideal seria você arrumar outro chip de reserva caso algo dê errado.

  11. #10
    Membro Avatar de Marc-BR
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jun 2001
    Mensagens
    3.240
    Verdinhas
    57

    Originalmente enviada por braziliantech
    Veja se o Uniflash consegue detectar o chip!!! Ele suporta mais chips que o AwardFlash. Se ele não detectar, está com problema mesmo.

    Olhe a marca/modelo do chip, retirando o selo sobre ele.

    Dependendo do modelo é "normal" acontecer isso às vezes (perder a ID).

    Mas é meio arriscado sim. O ideal seria você arrumar outro chip de reserva caso algo dê errado.
    bom, vou tentar fazer o q vc falou... mas nao pretendo atualiza a bios por enquanto... Eu estou trabalhando nessa maquina( Duron 1.2 Morgan + ECS K7SEM rev 1.0 + 256mb DIMM SDRAM PC133 Samsung ), sou programador... daqui uns 2 meses minha patroa falou que quer que eu monte uma nova maquina pra eu trabalhar... dai qd isso acontecer, talvez eu resolva atualizar a bios dessa placa mae.

    Mas vamo la... baixei o uniflash, no txt q veio no programa tem uma lista de comandos...

    UNIFLASH [-H|-?|[-PCIROM [B D F]|-AMI|-ASUS|-BASE xxxxx|CTFLASH [xxx]]
    [-E fname][-SAVE fname|-CHIPLIST|-FORCE xxxx][-REPAIR][-LOG][-MONO]
    [-CMOSS fname][-CMOSR fname][-CMOSC]][-UNLOCK][-QUIT][-REBOOT]

    -H or -? Shows this help screen
    -E fname Flashes fname to Flash ROM with no prompts
    -LOG Enables auto-logging to UNIFLASH.LOG
    -MONO Use if you have problems with colors on monochrome monitor
    -CTFLASH Flash ROM in c't Flasher 8-bit ISA card [xxx=port]
    -PCIROM Flash ROM on a PCI card instead of system ROM
    [BUS DEV FUN] Manually specify PCI device (decimal numbers)
    -AMI, -ASUS Use AMI Flash Interface, Use Asus Flash Interface
    -CHIPLIST Show list of supported flash chips with their numbers
    -FORCE xxxx Force using routines for chip xxxx (4 hex digits)
    -BASE xxxxx Set ROM Base to address xxxxx (at least 5 hex digits)
    -REPAIR Repair erased chip ID (Winbond and SST chips)
    -SAVE fname Write current bios image to file fname
    -CMOSS/R fname Save/restore CMOS settings to/from file fname
    -CMOSC Clears CMOS settings
    -UNLOCK Unlock locked bootblocks (e.g. on W29C020)
    -QUIT Quits (e.g. UNIFLASH -SAVE BACKUP.BIN -QUIT)
    -REBOOT Reboot after flashing (use together with -E)

    Qual comando eu devo usar? Esse " -REPAIR " ? (no caso de ser esse comando, nao tem perigo de acontecer nada naum?)

  12. #11
    Membro Avatar de Marc-BR
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jun 2001
    Mensagens
    3.240
    Verdinhas
    57

    hmmm tava lendo a respeito desse comando " -REPAIR " e tem tudo a ver com o q vc falou.... vc tava certo!

    uia: "-REPAIR: ID on some Winbond and SST chips can be changed which can cause the
    chip not being recognized by any software (including BIOS - AMI BIOS
    does not work in that chip, Award BIOS displays Unknown Flash Type).
    This option can change the ID on these chips. Because UniFlash does
    not know the correct ID, you must specify it using -FORCE parameter."

    nao entendi essa parte de "Because UniFlash does not know the correct ID, you must specify it using -FORCE parameter."

    Se o comando -REPAIR nao funcionar eu devo usar esse "-FORCE" ?

  13. #12
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Mar 2002
    Mensagens
    2.573
    Verdinhas
    336

    Não. Roda ele sem parâmetros.

    Se detectar o chip, vai aparecer na tela. E se não detectar, tira o selo que está sobre o chip e anote o modelo.

  14. #13
    Membro Avatar de Marc-BR
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jun 2001
    Mensagens
    3.240
    Verdinhas
    57

    Originalmente enviada por braziliantech
    Não. Roda ele sem parâmetros.

    Se detectar o chip, vai aparecer na tela. E se não detectar, tira o selo que está sobre o chip e anote o modelo.
    ok, vamo la

    1) fiz exatamente o q vc falou... reiniciei o computer e iniciei pelo disquete de boot do win98... dai rodei esse uniflash sem parametros e nao detectou a bios...
    apareceu assim na tela do programa uniflash
    " BIOS FLASH TYPE: UNKNOW
    ORGANISATION: N/A "
    (* naum foi erro ortografico meu, tava escrito "organisation" com "S" heheh)

    2) Eu abri o gabinete, aproveitei pra limpar e lavar o cooler e passar pasta termica q naum tinha, o processador estava a 67 grau, agora esta a 44 heheheh, o manual da placa mae tava la dentro... olhei, e achei um JUMPER (JP3) que é o "WRITE PROTECT".... mas ja tava default desativado... conferi certim. Tenho certeza de que o WRITE PROTECT estava jumpeado como DISABLED (segundo o manual).

    3) eu olhei o chip da bios.
    Em cima do chip da bios tinha 2 adesivos.
    No primeiro adesivo tava escrito isso:
    "
    K7SEM
    209
    "

    No segundo adesivo tava escrito isso
    "
    Phoenix BIOS
    D686 BIOS
    ®PHOENIX 1998
    084698172
    "

    Dai eu arranquei esses 2 adesivos pra ler o que estava escrito no chip da bios...
    no chip da bios estava escrito isso:
    "
    WINBOND
    W49F002U-12B
    222GH221049701SA
    "

  15. #14
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Mar 2002
    Mensagens
    2.573
    Verdinhas
    336

    Então tente:
    UNIFLASH -FORCE DA0B -REPAIR

    Compare o nome do chip exibido com aquele que você anotou antes de prosseguir.

    Faça o backup do BIOS e tente atualizar, incluindo o BootBlock.

    Por sua conta e risco! Mas pra quem estava tentando fazer com o AwardFlash, o risco é o mesmo.

    []s,
    Daniel

  16. #15
    Membro Avatar de Marc-BR
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jun 2001
    Mensagens
    3.240
    Verdinhas
    57

    Originalmente enviada por braziliantech
    Então tente:
    UNIFLASH -FORCE DA0B -REPAIR

    Compare o nome do chip exibido com aquele que você anotou antes de prosseguir.

    Faça o backup do BIOS e tente atualizar, incluindo o BootBlock.

    Por sua conta e risco! Mas pra quem estava tentando fazer com o AwardFlash, o risco é o mesmo.

    []s,
    Daniel
    cara, nem to afim de arriscar a atualizar a bios naum (por enquanto)

    sera que eh arriscado usar aquele comando UNIFLASH -FORCE DA0B -REPAIR ?

  17. #16
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    May 2003
    Mensagens
    3.590
    Verdinhas
    10

    Ja postei aqui a algum tempo e ate tem aver com isso ai, um colega meu foi na santa e comprou um pc usado mesmo eu tendo advertido ele, veio uma placa k7vza so que desta existem 2 modelos entao o q acontece, o pcb dela a da versao 1,0 e o bios e da 3,0 se nao me engano e toda vez que ele da boot no windows rapidamente na tela preta onde aparece os dados do pc em uma tabelinha no fim da tela embaixo aparece essa mensagem ai UNKNOW FLASH TYPE o que eu suponho e que o cara colocou a bios de uma versao 3,0 com defeito na 1,0 que devia estar com bios ruim ou entao ele gravou a bios errada por alguma daquelas maquinas que gravam bios. Eu tb tenho medo de colocar a bios certa e dar pau em tudo mesmo sendo preciso pq o micro dele nao esta reconhecendo um durom 1,6 e precisaria de uma bios mais nova para fazelo. Se vc arriscar posta ai para saber se deu certo provavelmente se eu tentar aqui vai dar a mesma coisa que da ai.

  18. #17
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    May 2003
    Mensagens
    3.590
    Verdinhas
    10

    Opa peguei o manual da k7vza aqui e estava lendo achei uma coisa, tem um "BIOS write jumper protect" pelo que entendi o jumper substitui a funçao da proteçao na bios sera que a sua nao esta ligada

  19. #18
    Membro Avatar de Marc-BR
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jun 2001
    Mensagens
    3.240
    Verdinhas
    57

    Originalmente enviada por Orthanc
    Opa peguei o manual da k7vza aqui e estava lendo achei uma coisa, tem um "BIOS write jumper protect" pelo que entendi o jumper substitui a funçao da proteçao na bios sera que a sua nao esta ligada
    isso.... eu ja sabia... exatamente o q eu tinha escrito la em cima...
    essa minha ECS K7SEM tambem tem esse jumper "WRITE PROTECT", mas veio jumpeado default em "DISABLED"

    Agora quero apenas saber se eu usar aquele comando do uniflash, se naum tem perigo

    Originalmente enviada por Marc-BR

    ok, vamo la

    1) fiz exatamente o q vc falou... reiniciei o computer e iniciei pelo disquete de boot do win98... dai rodei esse uniflash sem parametros e nao detectou a bios...
    apareceu assim na tela do programa uniflash
    " BIOS FLASH TYPE: UNKNOW
    ORGANISATION: N/A "
    (* naum foi erro ortografico meu, tava escrito "organisation" com "S" heheh)

    2) Eu abri o gabinete, aproveitei pra limpar e lavar o cooler e passar pasta termica q naum tinha, o processador estava a 67 grau, agora esta a 44 heheheh, o manual da placa mae tava la dentro... olhei, e achei um JUMPER (JP3) que é o "WRITE PROTECT".... mas ja tava default desativado... conferi certim. Tenho certeza de que o WRITE PROTECT estava jumpeado como DISABLED (segundo o manual).

    3) eu olhei o chip da bios.
    Em cima do chip da bios tinha 2 adesivos.
    No primeiro adesivo tava escrito isso:
    "
    K7SEM
    209
    "

    No segundo adesivo tava escrito isso
    "
    Phoenix BIOS
    D686 BIOS
    ®PHOENIX 1998
    084698172
    "

    Dai eu arranquei esses 2 adesivos pra ler o que estava escrito no chip da bios...
    no chip da bios estava escrito isso:
    "
    WINBOND
    W49F002U-12B
    222GH221049701SA
    "

+ Responder Tópico Ir para o Fórum

Assuntos do tópico

Compartilhar

Permissões