+ Responder Tópico
Página 1 de 5 1 2 3 ... Última
  1. #1
    hardMOB Staff - Moderação Avatar de 3,14k2|P1k4chu
    Info
    Registro
    Jun 2003
    Mensagens
    42.364
    Verdinhas
    653

    [Curiosidade] Pq o uso de CPU não vai a 100%?

    Opa pessoal beleza?

    Seguinte, sempre que eu jogava alguma coisa e tal no meu antigo Athlon64 o uso de CPU ia a 100%, sempre levei isso como normal, o CPU trabalha o maximo possivel em um jogo por exemplo, mas agora levei um susto!

    Não sei é pelo fato de ser Dual Core, de ser Intel, sei lá... nunca vi disso

    Liguei o suporte a SMP do Quake4 e porra... 23% de CPU usage... incrível!



    Alguem tem alguma explicação pra isso?

  2. # Publicidade
    Publicidade

  3. #2
    Membro
    Info
    Registro
    Jan 2002
    Mensagens
    22.948
    Verdinhas
    345

    Depois vamo fazer uns testes com MP rolando, pra ver como fica o CPU usage.

  4. #3
    Membro Avatar de agontijo
    Info
    Registro
    Jul 2002
    Mensagens
    1.001
    Verdinhas
    4

    Caralho, 23%!!!

    E o Q4 é bem dependente de CPU, realmente tá estranho isso! Mesmo sendo 23 + 23 de cada core, só usar "46%" ainda é pouco.

    Testa outro jogo pra ver Pika! Tipo o Fear assim.

    Abraço,
    AleX

  5. #4
    Membro Avatar de andrepmrj
    Info
    Registro
    Nov 2000
    Mensagens
    11.346
    Verdinhas
    449

    23% so ???????? nao, nao

    tem merda ai, que sacanagem e essa ??????


    esses coreduo ta tao foda assim ???????


    roda um bf2 e ve se bate 100% ou menos .

  6. #5
    Membro Avatar de Onilink
    Info
    Pescador de Caranguejo
    Registro
    Jan 2006
    Mensagens
    13.220
    Verdinhas
    331

    Fui só eu quem notou a quantidade absurda de programas abertos juntos com o jogo?

  7. #6
    Membro Avatar de Jaymz Hetfield
    Info
    Registro
    Oct 2004
    Mensagens
    3.056
    Verdinhas
    28

    Quero ver fazer isso com uma NFS7 + Barton 2600

  8. #7
    Membro
    Info
    Registro
    Jan 2002
    Mensagens
    22.948
    Verdinhas
    345

    Citação Citando andrepmrj Ver mensagem
    23% so ???????? nao, nao

    tem merda ai, que sacanagem e essa ??????


    esses coreduo ta tao foda assim ???????


    roda um bf2 e ve se bate 100% ou menos .
    Imagine o seguinte: Você considera o seu processador suficiente pra sua 8800GTX. Por você ter uma 8800GTX, suponho que você joga em resoluções bem altas, e nem nelas o seu CPU te deixa na mão.

    Agora imagina que um C2D a 2.8ghz é umas 6x melhor que o seu processador.

  9. #8
    Membro Avatar de DeatH
    Info
    GETTUDA CHOPPAH
    Registro
    Dec 1999
    Mensagens
    6.007
    Verdinhas
    788

    isso eh parte da arkitetura do cpu
    kdo xega no limite de 100%, o load eh transferido pro core mais prox e assim sucessivamente

  10. #9
    hardMOB Staff - Moderação Avatar de 3,14k2|P1k4chu
    Autor do tópico
    Info
    Registro
    Jun 2003
    Mensagens
    42.364
    Verdinhas
    653

    Continuo sem entender... os jogos SEMPRE foram a 100%, eita CPU da porra!

    Quake3 + Decoding de MonkeyAudio Lossless


    Quake3 + Decoding de MonkeyAudio Lossless + Windows Media Video HD 720p


    Como que pode uma porra dessas? To assustado, e é serio.

    Sempre ficou 100% de CPU quando eu jogava algo, sempre... desde que me entendo como poweruser e tal, nunca vi disso

  11. #10
    hardMOB Staff - Moderação Avatar de 3,14k2|P1k4chu
    Autor do tópico
    Info
    Registro
    Jun 2003
    Mensagens
    42.364
    Verdinhas
    653

    Citação Citando DeatH Ver mensagem
    isso eh parte da arkitetura do cpu
    kdo xega no limite de 100%, o load eh transferido pro core mais prox e assim sucessivamente
    Acho que não hein, tendo em vista que o Quake4 suporta SMP nativamente, e tomei o devido cuidado de ver se estava ativado.

    E agora o Quake3 junto com MAC e até tive a audacia de um 720p

    []'s

  12. #11
    Membro
    Info
    Registro
    Sep 2005
    Mensagens
    4.512
    Verdinhas
    320

    Creio q esteja usando 123% na verdade...100% de um core e 23% do outro...marcando assim somente 23%..

    Tenta fazer o seguinte...faz a msm coisa no windows vista...onde o msm ja tem suporte nativo a dual cores e o windows xp n...deve marcar 100%...

    ja se marcar 23% tb...ai ja n sei

    edit:

    lembrei de uma coisa...amigo meu uma vez disse q o css dele usava somente 50% do processador dele...e era um pentium 4...pode ser coisa de intel tb...
    Última edição por Badotti : 28-02-2007 às 0:22

  13. #12
    Membro
    Info
    Registro
    May 2006
    Mensagens
    658
    Verdinhas
    1

    show hein

    alguém já fez testes nos amd x2????

    para ver se é o fato de ser dual core ou só o c2d

  14. #13
    Membro
    Info
    Registro
    Aug 2004
    Mensagens
    3.838
    Verdinhas
    171

    Fake

    Processadores porreta esses core2duo...

  15. #14
    Membro Avatar de Peleyer
    Info
    Registro
    Oct 1999
    Mensagens
    7.636
    Verdinhas
    437

    A impressão que da é de que ele usa os dois nucleos pela metade, vai saber...


  16. #15
    Membro
    Info
    Registro
    Jan 2002
    Mensagens
    22.948
    Verdinhas
    345

    Citação Citando RBGGYN Ver mensagem
    Creio q esteja usando 123% na verdade...100% de um core e 23% do outro...marcando assim somente 23%..

    Tenta fazer o seguinte...faz a msm coisa no windows vista...onde o msm ja tem suporte nativo a dual cores e o windows xp n...deve marcar 100%...

    ja se marcar 23% tb...ai ja n sei

    edit:

    lembrei de uma coisa...amigo meu uma vez disse q o css dele usava somente 50% do processador dele...e era um pentium 4...pode ser coisa de intel tb...
    ? XP tem suporte nativo a multi-core sim.

  17. #16
    Membro Avatar de Repolho Roxo
    Info
    Registro
    Jan 2005
    Mensagens
    15.369
    Verdinhas
    2935

    Faz o seguinte então:

    Abre Quake4 + FEAR + Oblivion + HL2 one + video 720P.

    e vê como fica, se primeiro sua memória permitir.

  18. #17
    hardMOB Staff - Moderação Avatar de 3,14k2|P1k4chu
    Autor do tópico
    Info
    Registro
    Jun 2003
    Mensagens
    42.364
    Verdinhas
    653

    Citação Citando RBGGYN Ver mensagem
    Creio q esteja usando 123% na verdade...100% de um core e 23% do outro...marcando assim somente 23%..

    Tenta fazer o seguinte...faz a msm coisa no windows vista...onde o msm ja tem suporte nativo a dual cores e o windows xp n...deve marcar 100%...

    ja se marcar 23% tb...ai ja n sei

    edit:

    lembrei de uma coisa...amigo meu uma vez disse q o css dele usava somente 50% do processador dele...e era um pentium 4...pode ser coisa de intel tb...
    Acho que não cara, pelo simples fato de mostrar 2 cores e ainda mais o XP tem sim suporte NATIVO a DualCore... isso ja é velho nos sistemas operacionais.

    E ainda uma coisa, o Quake4 tem suporte a SMP, talvez isso explique mais ainda o fato do Quake4 ter um uso menor de CPU contra o Quake3 que me retorna um freeze quando boto: r_smp 1.

    Citação Citando Marcelino Ver mensagem
    show hein

    alguém já fez testes nos amd x2????

    para ver se é o fato de ser dual core ou só o c2d
    To vendo se compro um X2 até mês que vem... vamos ver! Tô precisando no meu HTPC.

    Citação Citando Peleyer Ver mensagem
    A impressão que da é de que ele usa os dois nucleos pela metade, vai saber...

    Tenho minhas duvidas, pq nesse caso do Trackmania ele nao usa SMP (tenho quase certeza que o Engine não permite).

    Citação Citando Repolho Roxo Ver mensagem
    Faz o seguinte então:

    Abre Quake4 + FEAR + Oblivion + HL2 one + video 720P.

    e vê como fica, se primeiro sua memória permitir.
    Cara, vou tentar sim, mas o Fear eu ja descarto primeiro pq eu so tenho o FEAR Combat aqui e outra o jogo nao fica Windowed, tentarei rodar 2 jogos ao mesmo tempo, MonkeyAudio e um 720p

    []'s

  19. #18
    Membro Avatar de AccellX®
    Info
    Registro
    Aug 2002
    Mensagens
    3.335
    Verdinhas
    110

    Eh assim mesmo..
    XP nunca usa 100% mesmo.. soh Vista que vai usar.. e os jogos novos





    Teste feitos com um Opteron165 e uma 7600gst (retirados de outro forum)

  20. #19
    hardMOB Staff - Moderação Avatar de 3,14k2|P1k4chu
    Autor do tópico
    Info
    Registro
    Jun 2003
    Mensagens
    42.364
    Verdinhas
    653

    Citação Citando AccellX® Ver mensagem
    Eh assim mesmo..
    XP nunca usa 100% mesmo.. soh Vista que vai usar.. e os jogos novos

    ...

    Teste feitos com um Opteron165 e uma 7600gst (retirados de outro forum)
    Mesmo assim se nota claramente que os picos foram bem altos, 23% em um jogo como o Quake4 é ridiculo!

    E como o Onlink abortou, estava com uma penca de programa (ainda estou) abertos... como eMule, uTorrent (comendo a 30k/s de Upload) e outras...

    Enfim... fiz um ultimo teste, e mesmo assim não consegui chegar a 100% do CPU. E so pra resaltar nao teve framedrop no video 720p

    Quake 3 + Quake 4 + Half Life 2: Episode One + MonkeyAudio Lossless + WMV HD 720p


    Fenomenal, estou assustado mesmo...

    []'s

  21. #20
    hardMOB Staff - Moderação Avatar de Spidey
    Info
    Registro
    Feb 2002
    Mensagens
    21.479
    Verdinhas
    1933

    caralho, agora quem está abismado sou eu

    PUTA Q PARIU, o processador é da NASA. literalmente

    porra, 60fps no quake4, hl2 e quake3 abertos e SEM FRAMEDROP NO HD VIDEO

    pqp, vc fez pacto com o demo? é sabido q até o TIBIA roda em 100% do processador po. q BIZARRO.

    é a virada do pikachu, o pé friismo dele acabou.eauiheaiuheaui. virou pé quente!
    eiuaehuiaheiuhueah

    agora sério, faz o teste, abre um tíbia e vê se não vai a 100%
    isso não existe, principalmente pra encoding, como q o processo não aproveita 100% do processador se quanto maior o processamento menos tempo leva?

    mas o absurdo é q o fato de rodar tudo liso demonstra q a porcentagem não é falsa. pqp, inveja sUx

  22. #21
    Membro
    Info
    Registro
    Apr 2001
    Mensagens
    2.576
    Verdinhas
    0

    Vsync ou o tempo dos ticks tão limitando quantas instruções por segundo o processador pode fazer. Não fique achando que isso é algum bug... está certo não usar todo o CPU se não é necessário.

    Se quizer faço um joguinho tosco que usa os 2 cores a 100% sem problema nenhum
    Última edição por Nero : 28-02-2007 às 2:14

  23. #22
    hardMOB Staff - Moderação Avatar de 3,14k2|P1k4chu
    Autor do tópico
    Info
    Registro
    Jun 2003
    Mensagens
    42.364
    Verdinhas
    653

    Citação Citando Nero Ver mensagem
    Vsync ou o tempo dos ticks tao limitando quantas instrucoes por segundo o processador pode fazer. Não fique achando que isso é algum bug... está certo não usar todo o CPU se não é necessário.

    Se quizer faco um joguinho tosco que usa os 2 cores a 100% sem problema nenhum
    Não po programar mal e mandar 2 loops infinitos até eu faço. A questão não é essa...

    A questão é que no meu A64 qualquer jogo ficava em 100%, inclusive por muitos aqui na hardMOB ja era lei: Qualquer jogo deixa qualquer CPU em 100%, pq o jogo sempre usa o maximo possivel de CPU Cycles (oq explica os FPS).

    O que eu estou assustado é justamente com isso, sem VSync, sem limitação de FPS os cores não chegam a 100%... e o pior ficam com usos ridiculamente baixos (23% com o Quake4).

    []'s

  24. #23
    Membro
    Info
    Registro
    Apr 2001
    Mensagens
    2.576
    Verdinhas
    0

    Não adianta desativar vsync somente, programação em threads no caso do Quake 4 pode ter rotinas de sincronização, ou alguma rotina de sleep nua e crua caso o processo tenha sido feito em uma velocidade acima da esperada.

  25. #24
    hardMOB Staff - Moderação Avatar de 3,14k2|P1k4chu
    Autor do tópico
    Info
    Registro
    Jun 2003
    Mensagens
    42.364
    Verdinhas
    653

    Citação Citando Nero Ver mensagem
    Não adianta desativar vsync somente, programação em threads no caso do Quake 4 pode ter rotinas de sincronização, ou alguma rotina de sleep nua e crua caso o processo tenha sido feito em uma velocidade acima da esperada.
    Bem ai realmente eu não sei, não sou expert em programação, sei apenas o basicão do basicão mesmo.

    Mas anyway pro Quake4 é valido e explica sim o low cpu-usage de 23%, mas o Quake3 com r_smp 1 ele da Freeze...

    Ta certo que o Quake3 foi a 46% de CPU (mas leva-se em conta o MAC [Monkey Audio Lossless] no fundo que gasta uns 4% de CPU).

    Mesmo assim, 46% não foi dividido corretamente entre os cores, rolou alguma folga, como falei o Quake3 ficava SEMPRE em 100% no Athlon64, agora no Core2 não foi que se mostrou.

    PS: Tem como eu desligar algum dos cores pra eu testar isso? É possivel?

    []'s

  26. #25
    Membro Avatar de TM99
    Info
    Registro
    Oct 1999
    Mensagens
    5.994
    Blogs
    1
    Verdinhas
    300

    Citação Citando 3,14k2|P1k4chu Ver mensagem
    Bem ai realmente eu não sei, não sou expert em programação, sei apenas o basicão do basicão mesmo.

    Mas anyway pro Quake4 é valido e explica sim o low cpu-usage de 23%, mas o Quake3 com r_smp 1 ele da Freeze...

    Ta certo que o Quake3 foi a 46% de CPU (mas leva-se em conta o MAC [Monkey Audio Lossless] no fundo que gasta uns 4% de CPU).

    Mesmo assim, 46% não foi dividido corretamente entre os cores, rolou alguma folga, como falei o Quake3 ficava SEMPRE em 100% no Athlon64, agora no Core2 não foi que se mostrou.

    PS: Tem como eu desligar algum dos cores pra eu testar isso? É possivel?

    []'s
    tem como vc fazer o jogo usar soh um processador sim

    Aperte control alt del, va em processos, e ali no processo do jogo vc clica com o botão direito e vai ter uma opção pra definir qual core o jogo deve usar, não lembro o nome da opção, acho que era "Cpu Afinity" ou "Afinidade de CPU" ele provavelmente vai tar marcado pra usar os 2 cores, tira um deles que ele vai ficar em um processador só.

    Inclusive isso é importante pq alguns jogos ficam mto esculhambados quando usam os 2 processadores, tipo o UT que fica engasgando, derrepente acelera 200% e engasga denovo...

    Ouvi falar tambem que drives de video/processador novos resolvem esse problema automaticamente, mas não pude testar pra ter certeza ..
    Última edição por TM99 : 28-02-2007 às 2:45

+ Responder Tópico Ir para o Fórum
Página 1 de 5 1 2 3 ... Última

Assuntos do tópico

Compartilhar

Permissões