+ Responder Tópico
  1. #1
    Membro
    Info
    Registro
    Mar 2003
    Mensagens
    1.310
    Verdinhas
    107

    DVD "comendo" toda CPU

    Meu DVD começou a comer 100% de um núcleo. Quando lê ou quando grava. E fica lento. Grava em 1x e lê pouco mais que isso.
    Pensei. Cabo (IDE) com problema. Troquei mas não resolveu. A princípio não tem nada errado.
    A princípio tudo ok. BIOS, windows. Não uso antivírus.

    Alguma ideia?

  2. # Publicidade
    Publicidade

  3. #2
    Jon
    Jon está offline
    Membro Avatar de Jon
    Info
    Registro
    Oct 2002
    Mensagens
    2.180
    Verdinhas
    3624

    Seu gravador está em modo PIO. Normalmente isto acontece quando acontecem uma determinada quantidade de erro de transmissão de dados entre a mobo e o gravador e, por segurança (creio), o windows joga para modo PIO. Vai no gerenciador de dispositivos e verifica isto. Aproveita o embalo e coloca um cabo ide novo também.

  4. #3
    Membro
    Autor do tópico
    Info
    Registro
    Mar 2003
    Mensagens
    1.310
    Verdinhas
    107

    Citação Citando Jon Ver mensagem
    Seu gravador está em modo PIO. Normalmente isto acontece quando acontecem uma determinada quantidade de erro de transmissão de dados entre a mobo e o gravador e, por segurança (creio), o windows joga para modo PIO. Vai no gerenciador de dispositivos e verifica isto. Aproveita o embalo e coloca um cabo ide novo também.
    Imaginei isso. Por isso chequei o BIOS. Só mudei para LBA no BIOS mas não deu efeito... Mas nele não tenho opções de configurar manual. Estranho, mas não consegui.Já havia procurado no Windows essa opção. Mas não achei. Procurei de novo agora e também nada. Aproveitei pra ver no HD, mas também não achei a opção. Numa pesquisa rápida não achei nada a respeito. Mas uso o XP 64 bits.
    Sobre o cabo IDE, já troquei. Foi minha primeira suspeita...

    Ainda bem que não enviei a mensagem. Achei na net. Procurei no local errado. Vi nas configurações do DVD e do disco, e não nas controladoras... Vou dar um boot pra ver se volta.
    Realmente estava em PIO. Mas jurava que isso era no DVD e não na controladora, apesar de fazer mais sentido assim mesmo...

  5. #4
    Membro
    Autor do tópico
    Info
    Registro
    Mar 2003
    Mensagens
    1.310
    Verdinhas
    107

    Não rolou. Deixei o BIOS em auto e também não adiantou. O maldito não sai de PIO.
    Será que DVD ferrado pode dar isso?

  6. #5
    Jon
    Jon está offline
    Membro Avatar de Jon
    Info
    Registro
    Oct 2002
    Mensagens
    2.180
    Verdinhas
    3624

    Você vai precisar de algum programinha para ajustar na marra o modo UDMA no windows. Isto é pane no OS. Procura no google algo como FIX UDMA. Mesmo assim, se tu notar que o windows está jogando de novo para PIO, isto indica que algo está realmente errado e causando muitos erros de I/O (o que faz o windows mudar para PIO)

  7. #6
    Membro
    Autor do tópico
    Info
    Registro
    Mar 2003
    Mensagens
    1.310
    Verdinhas
    107

    Não achei programas pra isso. Só chave de registro. Fiz pelas chaves.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0002

    DWORD
    ResetErrorCountersOnSuccess = 1

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000
    DWORD
    EnableUDMA66 = 1


    Mas não resolveu. Resolvi ver se tinha driver mais novo pras controladoras. Enquanto esperava baixar, resolvi excluir o DVD e a controladora. Ao detectar de novo, sem boot, voltou pra DMA.
    Uso de CPU aceitável.10 a 15% de um núcleo. Taxa de tranferência de 7 MB a 14 MB, com arquivos grandes e distintos (partes diferentes do disco, 3 arquivos por disco). Medidos pelo procexp.

    Agora não sei se foi o registro ou a exclusão dos dispositivos que resolveu. Vou acompanhar pra ver se não volta o problema.

    Valeu pela ajuda. Qualquer novidade atualizo as informações.

  8. #7
    Membro
    Autor do tópico
    Info
    Registro
    Mar 2003
    Mensagens
    1.310
    Verdinhas
    107

    Resolvido.

    Realmente parece que resolveu. Devia ser o flat cable.
    Haviam erros no event viewer. ATAPI e cdrom

    Achei uma documentação inetressante. Explica o que funcionou que eu estava na dúvida.
    http://www.microsoft.com/whdc/device...e/IDE-DMA.mspx

    For repeated DMA errors. Windows XP will turn off DMA mode for a device after encountering certain errors during data transfer operations. If more that six DMA transfer timeouts occur, Windows will turn off DMA and use only PIO mode on that device.

    In this case, the user cannot turn on DMA for this device. The only option for the user who wants to enable DMA mode is to uninstall and reinstall the device.

    Windows XP downgrades the Ultra DMA transfer mode after receiving more than six CRC errors. Whenever possible, the operating system will step down one UDMA mode at a time (from UDMA mode 4 to UDMA mode 3, and so on).

    All CRC and timeout errors are logged in the system event log.

+ Responder Tópico Ir para o Fórum

Assuntos do tópico

Compartilhar

Permissões