+ Responder Tópico
Página 1 de 2 1 2 Última
  1. #1
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Oct 2003
    Mensagens
    7.568
    Verdinhas
    585

    Como usar o nVidia PureVideo pra filmes x264?

    Li varios tutoriais, instalei varios codecs mas ainda to perdido aqui.

    Meu pc é um Athlon X2 3800 (com um leve overclock pra 2.2Ghz),sound blaster live, 2Gb DDR2 e a VGA é uma 7600GS (que segundo a nVidia suporta purevideo).
    Estou usando o windows 7 rc7100. Optei pelo 7 por ter o windows media center e algunas configuracoes que facilitam o uso do computador com TV 42" full HD como monitor.

    O fato é que em qualquer video 720p ou 1080p que abro o consumo do processador é muito alto, chegando a travar o micro em alguns videos 1080p.

    Andei lendo na net alguns tutoriais, baixei e instalei o nVidia PureVideo codec e também o Pure codec (pacote de codecs tipo k-lite). Mas praticamente todas as combinações que uso de filtros e decoderes o processamento fica muito alto, 60~70% em 720p e 1080p fica 100% as vezes, e trava quase sempre.

    Perguntas:

    Mantenho o Windows 7? Compensa instalar o XP MCE? (lembrando que no XP minha placa de captura funciona mas no 7 ainda nao consegui)
    Qual player usar?
    Quais codecs usar e como configurar?
    Será que preciso trocar de VGA? O ganho pra 1080p seria muito melhor com uma VGA low-end mais atual (tipo 4550 por ex)?

  2. # Publicidade
    Publicidade

  3. #2
    Membro Avatar de Prea do Mato
    Info Conteúdo e Citações Jogos Mensageiros
    Filhotes: 4567
    Registro
    Mar 2008
    Mensagens
    3.370
    Verdinhas
    2520

    Eu já rodei filmes em 1080p com uma geforce 8400GS, isso numa TV de 42". Até uns 720p não era pra sua 7600GS ficar peidando.
    Eu acho que vale você trocar essa vga por uma mais recente, até uma 9400GT ou 9500, e com o detalhe que já existe PureVideo HD 2. Player muito bom que você pode habilitar aceleração por hardware, é o VLC, ele é completo, já vem com codecs e você pode fazer N configurações.
    Sobre teu SO, seria bom você fazer um dual boot, XP e Seven.

  4. #3
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Mar 2003
    Mensagens
    20.930
    Verdinhas
    489

    serie 7 é mais limitada... mas usa o mediaplayer classic home cinema

  5. #4
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Sep 2005
    Mensagens
    1.372
    Verdinhas
    269

    so consegui fazer o purevideo funcionar na minha 8600mgt pelo mediaplayer classic home cinema..

  6. #5
    Membro Avatar de leo_bsb
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Nov 2007
    Mensagens
    566
    Verdinhas
    0

    o purevideo da série 7xxx é só pra mpeg2, ou seja, DVD.
    Pra blueray e vídeos x264 vc precisa de uma série 8xxx ou superior.
    Sua máquina tá fazendo aceleração por software, daí o consumo alto, mesmo usando o MPC Homecinema.
    Não tem solução pro seu problema.

  7. #6
    Membro Avatar de hirano
    Info Conteúdo e Citações Jogos Mensageiros
    hiranosan
    Registro
    Nov 2007
    Mensagens
    4.020
    Verdinhas
    251

    Citação Citando TheLittle Ver mensagem
    Mantenho o Windows 7? Compensa instalar o XP MCE? (lembrando que no XP minha placa de captura funciona mas no 7 ainda nao consegui)
    Qual player usar?
    Quais codecs usar e como configurar?
    Será que preciso trocar de VGA? O ganho pra 1080p seria muito melhor com uma VGA low-end mais atual (tipo 4550 por ex)?
    - Mantenha o Windows 7.
    - Use o Media Player Classic Home Cinema.
    - Codec use só o FFDshow, ele roda (quase)tudo. Só vai precisar de codecs extras pra RMVB (Real alternative codec) e Quicktime mov (Quicktime alternative codec).

    Troque de VGA. Qquer VGA da série 8 (Nvidia) ou série HD2xxx (da ATI) tem aceleração boa para vídeos, até mesmo as mais baratas.

  8. #7
    Membro Avatar de kuchyosenojutsu
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Mar 2003
    Mensagens
    1.192
    Verdinhas
    0

    desinstale tudo e instale o coreAVC

  9. #8
    Administrador Avatar de NoRRiTT
    Info Conteúdo e Citações Jogos Mensageiros
    ...
    Registro
    May 1999
    Mensagens
    15.767
    Verdinhas
    3848

    Citação Citando kuchyosenojutsu Ver mensagem
    desinstale tudo e instale o coreAVC

    2x !!!!!!!!!!!

  10. #9
    Membro Avatar de leo_bsb
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Nov 2007
    Mensagens
    566
    Verdinhas
    0

    o coreAVC é pago.
    o media player classic home cinema é de graça.
    as últimas versões, encontradas no www.xvidvideo.ru tem suporte ao PureVideoHD em qualquer MKV, e não só nos codificados dentro dos padrões.
    Sem falar que com o MPC HC vc não precisa instalar mais nada, nenhum pacote de codecs, ele roda tudo direto.
    Mas software pra tocar mídia é questão de gosto. Eu gosto do MPC HC e uso no meu HTPC e demais computadores.

  11. #10
    Membro
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Oct 2003
    Mensagens
    7.568
    Verdinhas
    585

    Vocês dizem que minha placa não tem encoder pra H264, mas segundo esse comparativo:

    http://www.nvidia.com/docs/CP/11036/...Comparison.pdf

    Ela tem os seguintes recursos:

    H.264 Decode Acceleration
    VC-1/WMV Decode Acceleration
    MPEG-2 Decode Acceleration
    High-Quality Scaling
    MPEG-2 Spatial-Temporal De-Interlacing

    O que ela não tem:

    H.264 Decode Acceleration with IDCT and CAVLC/CABAC
    VC-1/WMV Decode Acceleration with IDCT
    MPEG-2 Inverse Telecine

    Inclusive, tem várias placas da série 8 que não tem todos os recursos (algumas até menos que a minha).

    Então acho que o que está acontecendo é que eu não estou sabendo configurar do modo correto, já que pelo que andei lendo essa aceleração não é nativa e não é feita de modo transparente para o usuário.Inclusive, quando a aceleração realmente está funcionando, o uso do processador é coisa de 5% num filme 720p. (segundo este artigo: http://iphonedaily.net/other-news/ha...cpu-usage.html POR FAVOR LEIAM ELE)

    Ou posso estar falando besteira. De qualuqer forma irei testar as alternativas que me propuseram aqui, muito obrigado.

    Uma outra dúvida:

    existe diferença pra x264, H264, h264?


    Valeu!

  12. #11
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Sep 2005
    Mensagens
    1.372
    Verdinhas
    269

    vai no MPCHC

    No options -> playback -> output -> marca o EVR Custom
    No options -> internal filters -> transform filters-> marca o H264/AVC (DXVA)

    Roda o filme, vai em Play -> Filters -> Vai no filter do renderer e vê se o DXVA tá ativando..
    Última edição por ultrahle : 16-06-2009 às 17:08

  13. #12
    Membro Avatar de hirano
    Info Conteúdo e Citações Jogos Mensageiros
    hiranosan
    Registro
    Nov 2007
    Mensagens
    4.020
    Verdinhas
    251

    Citação Citando TheLittle Ver mensagem
    existe diferença pra x264, H264, h264?
    H264 e h264 é a mesma coisa, é um codec de vídeo. Também é chamado de AVC.

    X264 é uma implementação opensource de um codec h264. Ele é usado para codificar arquivos no formato h264.

  14. #13
    Membro Avatar de leo_bsb
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Nov 2007
    Mensagens
    566
    Verdinhas
    0

    infelizmente vc está errado.
    pra simplificar: se a placa não suporta a aceleração de blue ray ela tb não suporta aceleração dos MKVs HD.
    não é exatamente isso mas fica mais simples pra vc comparar as placas.

    a série 7xxx não tem suporte, a partir da série 8xxx tem (mais especificamente aquelas 3 marcadas no PDF da nvidia e depois as novas lançadas após o PDF). Eu achei estranho as 8800GTS não terem, mas me lembro vagamente na época do lançamento umas notícias desse tipo. Tanto que na época comprei uma 8500GT pra usar no meu HTPC, depois trocada por uma ATI HD4550.

    O colega lembrou outra coisa, tem que configurar o MPC HC pra Custom EVR pra usar a aceleração DXVA, além de baixar as últimas versões.

    Mas isso tudo é inútil pro seu caso, como eu falei a série 7xxx não suporta.


    Citação Citando TheLittle Ver mensagem
    Vocês dizem que minha placa não tem encoder pra H264, mas segundo esse comparativo:

    http://www.nvidia.com/docs/CP/11036/...Comparison.pdf

    Ela tem os seguintes recursos:

    H.264 Decode Acceleration
    VC-1/WMV Decode Acceleration
    MPEG-2 Decode Acceleration
    High-Quality Scaling
    MPEG-2 Spatial-Temporal De-Interlacing

    O que ela não tem:

    H.264 Decode Acceleration with IDCT and CAVLC/CABAC
    VC-1/WMV Decode Acceleration with IDCT
    MPEG-2 Inverse Telecine

    Inclusive, tem várias placas da série 8 que não tem todos os recursos (algumas até menos que a minha).

    Então acho que o que está acontecendo é que eu não estou sabendo configurar do modo correto, já que pelo que andei lendo essa aceleração não é nativa e não é feita de modo transparente para o usuário.Inclusive, quando a aceleração realmente está funcionando, o uso do processador é coisa de 5% num filme 720p. (segundo este artigo: http://iphonedaily.net/other-news/ha...cpu-usage.html POR FAVOR LEIAM ELE)

    Ou posso estar falando besteira. De qualuqer forma irei testar as alternativas que me propuseram aqui, muito obrigado.

    Uma outra dúvida:

    existe diferença pra x264, H264, h264?


    Valeu!

  15. #14
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Oct 2002
    Mensagens
    237
    Verdinhas
    0

    Usa o coreAVC que voce roda tranquilo qq video, ate os em 1080p, pois ele eh otmizado pra dualcore, ao contrario de ffdshow e afins.
    Sobre rodar sem usar o processador a melhor opção seria comprar uma 8400GS e usar o coreAVC com a opção de rodar usando o CUDA, com essa opção ativada consegui rodar filmes de 1080p com um bitrate bem ato, consumindo so 2% do processador, sendo que a velocidade do processador estava em 600 mhz, e detalhe sem nenhuma travada.
    E usando o coreAVC tem como vc ainda tirar proveito dos filtros do FFDShow.
    A vantagem de usar ffdshow + coreAVC(CUDA ativado), eh que da ate pra desligar o cooler do PC, deixando o PC bem silencioso, ainda mais se a intenção for um HTPC.

  16. #15
    Suspenso
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Apr 2009
    Mensagens
    629
    Verdinhas
    0

    Citação Citando NoRRiTT Ver mensagem
    2x !!!!!!!!!!!
    3x

    eh pago entre aspas né ... está disponivel na internet ... qq coisa voce testa e paga tb neh .... se n achar

  17. #16
    Membro
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Jan 2002
    Mensagens
    22.949
    Verdinhas
    345

    Existem várias versões do Purevideo. A sua placa é da primeira geração:

    http://en.wikipedia.org/wiki/NVIDIA_PureVideo

  18. #17
    Membro Avatar de andrepmrj
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Nov 2000
    Mensagens
    11.346
    Verdinhas
    449

    Citação Citando Tape Cleaner Ver mensagem
    Usa o coreAVC que voce roda tranquilo qq video, ate os em 1080p, pois ele eh otmizado pra dualcore, ao contrario de ffdshow e afins.
    Sobre rodar sem usar o processador a melhor opção seria comprar uma 8400GS e usar o coreAVC com a opção de rodar usando o CUDA, com essa opção ativada consegui rodar filmes de 1080p com um bitrate bem ato, consumindo so 2% do processador, sendo que a velocidade do processador estava em 600 mhz, e detalhe sem nenhuma travada.
    E usando o coreAVC tem como vc ainda tirar proveito dos filtros do FFDShow.
    A vantagem de usar ffdshow + coreAVC(CUDA ativado), eh que da ate pra desligar o cooler do PC, deixando o PC bem silencioso, ainda mais se a intenção for um HTPC.

    opa onde tem isso ??????

    blz ja achei, muito bom uso do cpu despencou de 35% para 5% hehehehh
    Última edição por andrepmrj : 18-06-2009 às 1:33

  19. #18
    Membro
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Oct 2003
    Mensagens
    7.568
    Verdinhas
    585

    Citação Citando Tape Cleaner Ver mensagem
    Usa o coreAVC que voce roda tranquilo qq video, ate os em 1080p, pois ele eh otmizado pra dualcore, ao contrario de ffdshow e afins.
    Sobre rodar sem usar o processador a melhor opção seria comprar uma 8400GS e usar o coreAVC com a opção de rodar usando o CUDA, com essa opção ativada consegui rodar filmes de 1080p com um bitrate bem ato, consumindo so 2% do processador, sendo que a velocidade do processador estava em 600 mhz, e detalhe sem nenhuma travada.
    E usando o coreAVC tem como vc ainda tirar proveito dos filtros do FFDShow.
    A vantagem de usar ffdshow + coreAVC(CUDA ativado), eh que da ate pra desligar o cooler do PC, deixando o PC bem silencioso, ainda mais se a intenção for um HTPC.
    Testei o coreAVC e realmente melhorou bastante o desempenho mesmo com a minha 7600GS. Bom, o uso do processador não caiu horrores mas pelo menos tá rodando 1080P sem travar.

    Valeu a dica dos que me indicaram coreAVC


    Citação Citando Saboya Ver mensagem
    Existem várias versões do Purevideo. A sua placa é da primeira geração:
    É. Devia ter lido o artigo antes de ficar teimando aqui hehehe.


    bom, continuando com o meu caso:


    Peguei uma 8400GS que tinha aqui no meu trampo pra testar. Usando coreAVC + MPC HC, render EVR (vista/.net3) consegui ativar a aceleração do hardware. Imagem excelente e uso do processador bem baixo (em torno de 10%). O problema agora é que não aparecem legendas.
    Estive lendo ontem em alguns foruns gringos e vi que as legendas são exibidas no vídeo através de renderização por software. Se for isso mesmo nao vai adiantar muito usar a aceleração por hardware.

    E agora? Qual a saída?

  20. #19
    Membro Avatar de Cherno Alpha
    Info Conteúdo e Citações Jogos Mensageiros
    U.S.S.R.
    Registro
    Jan 2003
    Mensagens
    14.594
    Verdinhas
    1854

    EVR Custom Preset

    Depois vai em Playback e marca "Auto Load Subtitles"

    Coincidência, tenho quebrado a cabeça essa semana justamente com isso, soh q tenho uma HD3850.

    Ja ouviu falar no Shark007 Codecs? Da uma olhada... tem dado excelentes resultados aki...

    http://shark007.net/index.html

  21. #20
    Membro
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Oct 2003
    Mensagens
    7.568
    Verdinhas
    585

    Filme Madagascar 2 1080p x264

    Resultados com a 8400GS, uso da CPU:

    Código:
    Player        Video Renderer         H.264 Video Decoder            CPU Load AVG             Subtitles
    
    MPCHC      EVR (vista/.net3)         CoreAVC                           10%                          no
    MPCHC      VMR9 HQ Subtitles         CoreAVC                           60%                         yes
    MPCHC      VMR9 HQ Subtitles         Cyberlink DXVA for MKV            85%                         yes
    Última edição por TheLittle : 18-06-2009 às 9:46

  22. #21
    Membro
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Oct 2003
    Mensagens
    7.568
    Verdinhas
    585

    Citação Citando Apoca Ver mensagem
    EVR Custom Preset

    Depois vai em Playback e marca "Auto Load Subtitles"

    Coincidência, tenho quebrado a cabeça essa semana justamente com isso, soh q tenho uma HD3850.

    Ja ouviu falar no Shark007 Codecs? Da uma olhada... tem dado excelentes resultados aki...

    http://shark007.net/index.html
    putz velho, usando EVR Custon Preset o video fica dando umas travadinhas... o consumo de CPU é baixo, mostra as legendas mas não fica "liso" o vídeo..
    o que pode ser?

  23. #22
    Membro Avatar de Cherno Alpha
    Info Conteúdo e Citações Jogos Mensageiros
    U.S.S.R.
    Registro
    Jan 2003
    Mensagens
    14.594
    Verdinhas
    1854

    Citação Citando TheLittle Ver mensagem
    putz velho, usando EVR Custon Preset o video fica dando umas travadinhas... o consumo de CPU é baixo, mostra as legendas mas não fica "liso" o vídeo..
    o que pode ser?
    Owww eu tb baixei esse madagascar

    E aki tb dá uns flicks e travadinhas. A explicação q tenho encontrado é q o straming desse MKV não é compatível com o decoder.

    Pra poder tirar a prova, baixei um sample em h.264 com extensão .mov (Star Trek, vc acha em Torrent) e inclusive no site da ATI este formato é citado como full-compliant. Rodou liso e o cpu não passou de 15%

    Já no caso de WMV full HD e alguns tipos de MKV, noway msm, ou cpu pula pra 50% ou dá flicks/sem audio...

    Edit: Soh testo com 1080p.

    Com o Shark007 consegui rodar Mpeg4 em geral via hardware (por causa do UVD da Radeon)

  24. #23
    Membro
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Oct 2003
    Mensagens
    7.568
    Verdinhas
    585

    Citação Citando Apoca Ver mensagem
    Owww eu tb baixei esse madagascar

    E aki tb dá uns flicks e travadinhas. A explicação q tenho encontrado é q o straming desse MKV não é compatível com o decoder.

    Pra poder tirar a prova, baixei um sample em h.264 com extensão .mov (Star Trek, vc acha em Torrent) e inclusive no site da ATI este formato é citado como full-compliant. Rodou liso e o cpu não passou de 15%

    Já no caso de WMV full HD e alguns tipos de MKV, noway msm, ou cpu pula pra 50% ou dá flicks/sem audio...

    eh... as travadinhas são só no começo mesmo.. deixei o filme rodando um tempo e até agora ta rodando certinho.


    Falando em áudio, outro problema que eu to tendo é Sound Blaster Live + Windows 7 (driver gambiarra) + SPDIF Passthrough.. As vezes funciona, as vezes não, as vezes dá um chiado insuportável. E no XP funcionava bem. Agora to usando a Realtek onboard pra ver filme, já que o redirecionamento SPDIF dela funciona sempre.

  25. #24
    Membro Avatar de Cherno Alpha
    Info Conteúdo e Citações Jogos Mensageiros
    U.S.S.R.
    Registro
    Jan 2003
    Mensagens
    14.594
    Verdinhas
    1854

    Citação Citando TheLittle Ver mensagem
    eh... as travadinhas são só no começo mesmo.. deixei o filme rodando um tempo e até agora ta rodando certinho.


    Falando em áudio, outro problema que eu to tendo é Sound Blaster Live + Windows 7 (driver gambiarra) + SPDIF Passthrough.. As vezes funciona, as vezes não, as vezes dá um chiado insuportável. E no XP funcionava bem. Agora to usando a Realtek onboard pra ver filme, já que o redirecionamento SPDIF dela funciona sempre.
    Aki não rola, fica o tempo todo com flicker e sem audio...

    Aliás, alguns DivX/XviD tb não rolam via HW... ainda não achei o motivo pq alguns antigos reproduzem sem problemas enqto q alguns novos, não.

    Falta mto ainda pra acertar esses features no Seven.

  26. #25
    Membro
    Autor do tópico
    Info Conteúdo e Citações Jogos Mensageiros
    Registro
    Oct 2003
    Mensagens
    7.568
    Verdinhas
    585

    Citação Citando Apoca Ver mensagem
    Aki não rola, fica o tempo todo com flicker e sem audio...

    Aliás, alguns DivX/XviD tb não rolam via HW... ainda não achei o motivo pq alguns antigos reproduzem sem problemas enqto q alguns novos, não.

    Falta mto ainda pra acertar esses features no Seven.

    você ta usando o seven também?

+ Responder Tópico Ir para o Fórum
Página 1 de 2 1 2 Última

Assuntos do tópico

Compartilhar

Permissões