+ Responder Tópico
  1. #1
    hardMOB Staff - Moderação Avatar de Kyle
    Info
    Registro
    Nov 1999
    Mensagens
    13.635
    Verdinhas
    5093

    HD Morrendo? Não formata, não instala, não reconhece direito, não nada :(

    O computador da minha tia do nada parou de entrar no Windows, resolvi formatar e percebi que quando eu coloava para formatar no modo normal (sem ser o rápido) ele ficava nos 0% eternamente. Voltei e coloquei pra formatar rápido e formatou, ok.
    Na hora de instalar o Windows, depois das configurações de rede e etc ele deu um erro como se o arquivo do CD não pudesse ser encontrado, pensei que era o CDROM, mas cada vez que eu reiniciava toda a instalação o mesmo erro acontecia falando que não encontrava um arquivo mas sempre era um arquivo diferente do anterior.

    Bom, resolvi testar esse HD em outro PC pra ver se formatava e instalava, quando eu menos espero o HD na real era de 80GB mas só reconhecia como 40GB, a mesma coisa aconteceu em outro computador que coloquei esse HD, ele reconhecia apenas como 40GB e durante a instalação do Windows deu aquela tela azul de hardware.

    Voltei o HD pro computador original e tentei dar um CHKDSK porém acontece a mesma coisa da formatação normal, chega em uma certa porcentagem e ele fica lá parado eternamente, passam horas e ele não sai do lugar.

    To desconfiando que o HD pode estar morrendo, alguém confirma?
    Alguém tem alguma dica de algo que eu posso confirmar melhor se é realmente o HD que está morrendo?

    Vlw []'s

  2. # Publicidade
    Publicidade

  3. #2
    Membro
    Info
    Registro
    May 2009
    Mensagens
    14
    Verdinhas
    0

    e ai blz

    ja tive um problema parecido com esse seu,testou o hd com outro cabo FLAT ou SATA,bom o que fiz pra tentar contornar esse problema foi o seguinte,tive que particionar o hd,nao deixe ele criar a partição sozinho vc mesmo tem que criar manualmente,criar a partição c: e depois criar uma partição d: e ai vc seta pra instalar o windows na partição d: pois acredito que o começo do hd ta zuado então ele deixa de lado essa parte,bom foi isso que fiz no meu caso e funcionou normalmente,mas o começo do hd estava cheio de bad block e por isso nao instalava e sempre dava erro quando colocava o cd de instalação parecendo que e erro do cd ou do drive de cd room que nao esta lendo, mas realmente era aquela parte o hd que estava defeituosa

  4. #3
    Membro Avatar de lordmac
    Info
    Registro
    Nov 2007
    Mensagens
    7.993
    Verdinhas
    6735

    Existem softwares que fazem uma varredura no disco e separam os pontos corrompidos dele em um setor separado.
    Vá ao site do fabricante do hd, pegue o software e veja se o problema é solucionado.

    Ja o fato dele só reconhecer 40Gb, atualize o BIOS da placa mae.

  5. #4
    Membro Avatar de Hasgul
    Info
    Derp
    Registro
    Jan 2005
    Mensagens
    4.891
    Verdinhas
    156

    Cara, ja tive um problema mto parecido com o seu, depois de mto teste resolvi trocar o cabo flat e era aí que estava o problema. Talvez não seja o seu caso, mas vale a pena tentar

  6. #5
    hardMOB Staff - Moderação Avatar de Kyle
    Autor do tópico
    Info
    Registro
    Nov 1999
    Mensagens
    13.635
    Verdinhas
    5093

    Bom estou utilizando a net aqui por ele fazendo o esquema que o ricksilaba falou, fiz 2 partições e instalei o Windows na última e funcionou.

    Sobre reconhecer como 40gb eu sei que não é da BIOS porque coloquei esse HD em 3 computadores diferentes e nos 3 ele reconheceu apenas como 40gb.
    O curioso foi que eu bootei o Linux pelo pendrive para ver o que dava pra fazer nesse HD e no /proc/partitions ele reconhecia:
    /dev/hda com 80gb
    /dev/hda1 com 40gb

    o hda1 era uma partição do hd de 80, mas por mais que eu tentasse pelo fdisk do Linux fazer as partições e etc a BIOS e o Windows sempre reconhecia apenas os 40gb. Tentei fazer várias partições primárias no hda com sistema ntfs, fat32, e nada. Sempre elas sumiam e virava apenas um HD de 40gb.

    Se eu tentasse aquele esquema de "zerar" (dd if=/dev/zero of=/dev/hda bs=1k) o HD, dava vários erros, e se eu particionasse o HD de 80gb como ext2, formatasse como ext2 e tentava passar o fsck pra checkar o disco, ele tb travava assim como o chkdsk do Windows.

    Única solução mesmo que deu certo foi entrar na instalação do Windows e fazer 2 partições e instalar na última, mas vamos ver quanto tempo vai durar

  7. #6
    Membro Avatar de lordmac
    Info
    Registro
    Nov 2007
    Mensagens
    7.993
    Verdinhas
    6735

    Ele nao ta com o jumper que limita o tamanho dele?
    Amigo, pega no site do fabricante a ferramenta para formatar em low level, quase certo que resolva seu problema.

  8. #7
    hardMOB Staff - Moderação Avatar de Kyle
    Autor do tópico
    Info
    Registro
    Nov 1999
    Mensagens
    13.635
    Verdinhas
    5093

    Citação Citando lordmac Ver mensagem
    Ele nao ta com o jumper que limita o tamanho dele?
    Amigo, pega no site do fabricante a ferramenta para formatar em low level, quase certo que resolva seu problema.
    Ele tinha essa informação de jumper para limitar o tamanho, mas ele dizia que limitava para 30gb e como era diferente dos 40gb que reconhecia então imaginei que não tinha nada haver.
    Bom, como o computador ela usa pra acessar a internet e abrir o word então deixei com 20gb e entreguei agora mesmo pra ela, vamos ver quanto tempo dura hehe.

    Se voltar a dar problema irei tentar esse esquema de ferramenta do fabricante, vlw.

+ Responder Tópico Ir para o Fórum

Compartilhar

Permissões