+ Responder Tópico
Página 1 de 2 1 2 Última
  1. #1
    Banido
    Info
    Registro
    Apr 2003
    Mensagens
    9.791
    Verdinhas
    3

    Emulando Gforce Fx no Doom3

    Bom semana passada depois de ter problemas com o Dx9 e a serie 43.xx -inclusive o Doom3 nao rodava, ficava uma tela cinza, eu havia reinstalado tudo de novo e voltei pra minha velha e confiavel combinacao classica:

    WindowsXp sem nenhum update

    Dx8.1

    Drivers 40.52

    A performance eh muito , mas muito boa mesmo nessa config, mas quando fomos (eu e black omega) fazer comparativos de demos do doom3 atraves de Timedemos, me estranhou muito q mesmo vendo q eu conseguia ate o dobro de Fps numa determinada screenshot, fikava pra traz no resultado do timedemo.

    Eu acho q isso se deve ao fato de o Alpha da E3 ter sido feito e optimizado pra apresentar uma demo na R300, sem falhas e evitando ao maximo um fiasco na apresentacao da Id software durante o evento.


    Depois de tentar descobrir o q podia ser, sem sucesso, resolvi partir de novo pro Dx9 e instalei o ultimo driver da Nvidia, o 43.51.

    Era o passo obvio pois eu tava rodando uma engine de ultimissima geracao em Dx/drivers bem velhinhos, pois o Dx8.1 e o 40.52 se nao me engano ja tem mais de um ano, por baixo.

    So tinha um pobrema, eu ja havia tentado rodar o Doom com outro driver 43.xx e rolava a porkera da tela cinza.
    Vc podia (as cegas) baixar o console e digitar comandos, o jogo funcionava em si, mas a imagem nao.
    Minha primeira esperanca era de q fosse o driver, entao como o 43.51 eh mais recente do q o q eu havia testado, resolvi tentar, mas la veio a telinha cinza de novo.

    Agora a esperanca era de q o driver funcionasse corretamente com o Dx9, pois foi feito pra ele, entao la fui eu pro caminho sem volta e taskei o Dx9a denovo.

    Tcharan!!!

    Tela cinza...

    Tinha 2 dias q eu havia reinstalado o windows, justamente pq tava tendo o mesmo pobrema.

    E o pior eh q o Pc fica do lado da janela...

    Enquanto eu me decidia se catava o Hd reserva e o cd do uindous ou se tacava tudo no concreto do playground e ia pra praia, veio a luz:

    Eu tinha ha quase um ano um arkivinho xule da Nvidia, q teoricamente seria um "Nv30 emulator", mas q nunca havia funfado.

    Desencavei ele das entranhas do Pc e liguei:

    Porra num eh q o joguinho entrou com tudo?

    Quando fui no riva (o mais atual) vi q as opcoes de emulacao da Nv30 tbm tinham sido habilitadas, desliguei o meu emuladorzinho By Nvidia e relaxei.

    Estava permanentemente no "Nv30 mode"

    A imagem ficou meio ruim, como se o shader tivesse poucos niveis, ficava umas listras nas sombras em vez de rolar smooth.

    Isso foi resolvido ligando todas as opcoes de qualidade do painel da Nvidia no maximo. Ficou lizinho.

    Next:

    R_useNv20 0

    R_useNv30 1

    Exec highquality, image_anizo 1.

    Funfou, nunca havia rolado isso antes, a imagem ficava toda bugada, mas agora...pqp...os glares tao muito mais suaves. A imagem ta mais real, mais glossy. Talvez devido ao driver novo, talvez devido a emulacao..sei la.

    Eu sei q a emulacao nao parece estar sendo feita pela Cpu conforme o esperado.

    Nao houve perda de performance, alias, o result da bench saltou de 34/36 pra 38/40, uma ganho de mais de 10% no resultado.

    O ganho maior foi q agora o AA/AF estao muiiiito, mas muiiito mais leves.

    O doom3 ainda da uns crashs basicos, mas isso eh devido ao pc aki estar rodando no top, com a bios puxada em tudo q tem direito.Foda-se, vai continuar assim.

    No Ut, mesmo com tudo q eh opcao pra D3d no talo da qualidade tbm nao houve perda de performance.

    Da pra tirar 2 conclusoes disso tudo:

    1-Ainda ha espaco pra melhora de performance e qualidade nas G4.

    2-A engine do Doom3 deve ficar muito, mas muito mais leve do q se imagina q vai ficar.



    Bom eh isso, Dx8.1 e o 40.52 foram muito bons, mas agora parece q vou migrar definitivamente pra Dx9/43.51.

    =========================

    Filez:

    Dx9a

    Det's 43.51

    NvEmulate.exe

    RivaTuner 2.0 Release Candidate 12.3

    =========

    Screens:

    (tirei pq ficou ruim de ler o topic)
    http://www.lizardkingdesigns.hpg.ig....fl_album2.jpeg
    this is an ingame screenshot

    tem mais 2 shotz nesse topic:

    http://forum.hardmob.com.br/showthre...02#post2122902

    Depois eu posto uns em Fp.

    []'s

  2. # Publicidade
    Publicidade

  3. #2
    Membro Avatar de duferrari
    Info
    Registro
    Apr 2002
    Mensagens
    2.367
    Verdinhas
    0

    Será que dá pra melhorar o desempenho do AA/AF da G4 através dos drivers?

  4. #3
    Suspenso
    Info
    Registro
    Apr 2002
    Mensagens
    2.766
    Verdinhas
    0

    Originalmente enviada por duferrari
    Será que dá pra melhorar o desempenho do AA/AF da G4 através dos drivers?
    Isso é meio obvio q não, so se a nVidia usar akeles macetes dela...

  5. #4
    Banido
    Autor do tópico
    Info
    Registro
    Apr 2003
    Mensagens
    9.791
    Verdinhas
    3

    Originalmente enviada por duferrari
    Será que dá pra melhorar o desempenho do AA/AF da G4 através dos drivers?
    Num sei, eu sei q depois q eu fiz tudo isso ficou tudo mais leve e mais fluido, inclusive os filtros.

    Os Filtros da Ati sao mais leves simplesmente por q nao filtram a cena toda, alem de deslocarem a metade dos pixels q os filtros "normais" delocariam.

    Apesar da qualidade do filtro ser pior, por isso ele eh mais leve, nao da pra perceber.

    Eh um "macete". Muito bem bolado por sinal.

  6. #5
    Membro
    Info
    Registro
    Jul 2001
    Mensagens
    3.098
    Verdinhas
    0

    Tenta rodar o Dawn Demo da NV30, eu tentei rodar essa bosta aqui mas falta 4 extensões de API que minha placa nao suporta
    Pega no site da Nvidia (posta screenshot )

  7. #6
    Membro Avatar de duferrari
    Info
    Registro
    Apr 2002
    Mensagens
    2.367
    Verdinhas
    0

    Originalmente enviada por Diesel Rj
    Num sei, eu sei q depois q eu fiz tudo isso ficou tudo mais leve e mais fluido, inclusive os filtros.
    Tem números?

  8. #7
    Banido
    Autor do tópico
    Info
    Registro
    Apr 2003
    Mensagens
    9.791
    Verdinhas
    3

    tirei umas screens do doom3, se kiserem eu posto.

    Tem uma quando abre o mapa 2, sem tocar no controle @ 31/32 fps (varia por causa da luz piscando, nao conferi)

    Com Aniso 3x e AA4 quincux

    Na pratica, ta dando pra jogar trankilo assim (AA4xq+AF3x) @ 800x600 mole.

    Isso numa G4, AA+AF no DOOM3 eh bem bacana, especialmente no athlonzinho.

    To loco pra chegar as memos do P4 pqp...

  9. #8
    Membro Avatar de duferrari
    Info
    Registro
    Apr 2002
    Mensagens
    2.367
    Verdinhas
    0

    Posta as SS

  10. #9
    Membro
    Info
    Registro
    Jan 2001
    Mensagens
    1.174
    Verdinhas
    0

    Originalmente enviada por Diesel Rj
    tirei umas screens do doom3, se kiserem eu posto.

    Tem uma quando abre o mapa 2, sem tocar no controle @ 31/32 fps (varia por causa da luz piscando, nao conferi)

    Com Aniso 3x e AA4 quincux

    Na pratica, ta dando pra jogar trankilo assim (AA4xq+AF3x) @ 800x600 mole.

    Isso numa G4, AA+AF no DOOM3 eh bem bacana, especialmente no athlonzinho.

    To loco pra chegar as memos do P4 pqp...
    põe ae!!

  11. #10
    Banido
    Autor do tópico
    Info
    Registro
    Apr 2003
    Mensagens
    9.791
    Verdinhas
    3



    Ss's da entrada da fase 2, sem mexer no mouse.

    Specs: 1024x768 4xAAquincux + 3xAF + Lod 3 + todas as opcoes do driver na qualidade maxima.

    Benchs do Unreal:

    Tbm com tudo no max, menos o Lod, q apesar de estar em maximum quality no painel da Nvidia eu eskeci de botar pra 3 no Rivaturner daki a pokinho eu testo o 1024 pra ver se da diferenca.

    Res. AA4q+AF2x - Normal (flyby/BotMatch)

    1024 - 97/57 - 164/64

    1200 - 62/41 - 127/63

    1600 - 32/24 - 86/55

    []'s

  12. #11
    Banido
    Autor do tópico
    Info
    Registro
    Apr 2003
    Mensagens
    9.791
    Verdinhas
    3



    A qualidade @ 1660x1200 + filtros (cropped pra vizualizar melhor)

  13. #12
    Membro Avatar de RYUDO
    Info
    Registro
    Jun 2002
    Mensagens
    1.867
    Verdinhas
    0

    nossa incrivel esses graficos
    show de bola deco

  14. #13
    UmK
    UmK está offline
    Suspenso
    Info
    Registro
    Aug 2000
    Mensagens
    12.180
    Verdinhas
    7

    Originalmente enviada por Diesel Rj


    A qualidade @ 1660x1200 + filtros (cropped pra vizualizar melhor)
    sabe oq ta parecendo?
    ta parecendo q ta sem bumpmapping
    ta horrivel, ta estranhao esse personagem ae, ta sem brilho, moh feio... realmente, tem ctz q n fudeu algo?
    isso ae ta parecendo textura comum
    realmente, a parede tbem ta sem brilho, tudo fosco
    opaa axei uma falhaaaaaa

  15. #14
    Membro
    Info
    Registro
    Jul 2001
    Mensagens
    3.098
    Verdinhas
    0

    Ueh, ta sem bumpmapping mesmo ...

  16. #15
    Membro
    Info
    Registro
    Apr 2002
    Mensagens
    5.074
    Verdinhas
    1521

    sem querer ser viado...mais eu curti o braço do cara...

    tah mto real

  17. #16
    Membro Avatar de duferrari
    Info
    Registro
    Apr 2002
    Mensagens
    2.367
    Verdinhas
    0

    É... Tá estranho...

    E seus resultados no UT estão ótimo

  18. #17
    Membro
    Info
    Registro
    Jul 2002
    Mensagens
    158
    Verdinhas
    0

    Pelo amopr de DEUS, esse jogo já saiu?????

  19. #18
    Membro
    Info
    Registro
    Jan 2001
    Mensagens
    1.174
    Verdinhas
    0

    Originalmente enviada por celols
    Pelo amopr de DEUS, esse jogo já saiu?????
    Não.

  20. #19
    Banido
    Autor do tópico
    Info
    Registro
    Apr 2003
    Mensagens
    9.791
    Verdinhas
    3

    Originalmente enviada por duferrari
    É... Tá estranho...

    E seus resultados no UT estão ótimo
    Ta nada, no P4 @ 1024 era de 182/84

  21. #20
    Banido
    Autor do tópico
    Info
    Registro
    Apr 2003
    Mensagens
    9.791
    Verdinhas
    3



    foquin chit!! num eh q eh verdade!! cade o brilho q tava aki??????

    uauhaauhuhauhauhaauh ki merdja!!!

    agora que sera q eu tenho q ligar pra essa jossa voltar ao normal??

  22. #21
    Membro
    Info
    Registro
    Apr 2001
    Mensagens
    2.331
    Verdinhas
    1

    Originalmente enviada por ericleon
    sem querer ser viado...mais eu curti o braço do cara...
    hummm...vc curtiu o braço do cara...ihhhh

    ...hummmm...não sei não, hein!!...

    zoeira.

  23. #22
    Membro
    Info
    Registro
    Apr 2001
    Mensagens
    2.331
    Verdinhas
    1

    Originalmente enviada por Diesel Rj
    foquin chit!! num eh q eh verdade!! cade o brilho q tava aki??????
    uauhaauhuhauhauhaauh ki merdja!!!
    agora que sera q eu tenho q ligar pra essa jossa voltar ao normal??
    escreve ae no console:

    condump cvarlist.txt

    vai criar um arquivo, listando todos as variáveis

    para todos os comandos:

    condump commands.txt

  24. #23
    Membro Avatar de duferrari
    Info
    Registro
    Apr 2002
    Mensagens
    2.367
    Verdinhas
    0

    Originalmente enviada por Diesel Rj

    foquin chit!! num eh q eh verdade!! cade o brilho q tava aki??????

    uauhaauhuhauhauhaauh ki merdja!!!

    agora que sera q eu tenho q ligar pra essa jossa voltar ao normal??
    Tava bom de mais né

  25. #24
    Banido
    Autor do tópico
    Info
    Registro
    Apr 2003
    Mensagens
    9.791
    Verdinhas
    3

    Okz, era simples o pobrema:

    O Doom roda no default assim:

    r_usestantardGl 0

    r_useGl2 0

    Eu tava usando:

    r_usestandardGl 1

    Ou seja, com standard ele sumia com um shader ou varios e provavelmente nao usava o emulador, mesmo estando com o r_useNv30 ligado..

    Eu tava meio desconfiado de algo, mas nao sabia o q:

    "Eu sei q a emulacao nao parece estar sendo feita pela Cpu conforme o esperado."

    Soh quando o Umk q o Black viram a imagem s/ shader (q eu tava achando linda ) eh q eu me tokei q tinha algo errado.

    Pior q a imagem tava diferente mesmo, mas eu tava amarradao, pra kem mexe com 3d/maya, parecia q tinha saido um blinn e entrado um (err eskeci o nome, um tipo aco escovado, sono ta foda)

    Enfim..

    Antao, era esse o pobrema, mas so q o seguinte, quando eu botei pra rodar no default o emulador entrou e funcionou meesmo, meteu o peh na porta e tacou tudo em cima do meu Xpzinho TbA e eu fui o feliz ganhador de:

    0,00000000000001 FPS!!

    Com o emulador mandando o render pro proc ficou pesando mais ou menos umas 675 toneladas


    Ae vcs vao me perguntar:

    Antao tudo isso q vc fez reinstalando Dx9, driver e etc foi a toa? Esse emulador nao serve pra foquin chit nenhuma??


    Err...bem..... quase (ufa!).

    Acontece q o Doom3 nao roda imagem com os novos detonators 43XX, mas porem, ligando o emulador de Nv30 o jogo rodara sem pobremas, com otimo Fps.

    Pelos menas eu arresolvi esse pobremia, por isso q eu amo a Nvidia, sempre tem um jeito de vc resolver sua vida.

    Ate pra kem eh antaman feito eu

    Com essa eu vo dormi, amanha tamos ae.

    []'s

  26. #25
    fsn
    fsn está offline
    Membro
    Info
    Registro
    Oct 2001
    Mensagens
    4.938
    Verdinhas
    785

    tá, mal por resussita o tópico, mas EU PRECISO faze esse d3 aqui funfar...

    Minha config tá ali em baixo, gf4ti 8x, 1800+ (stock), etc..

    antes de clocar o NVEmulate, ficava tela cinza, igualzinho ao que o disel flw, coloquei o NVemulate, entrou, MAS o jogo roda 0,000000001fps demora quase 1 minuto pra troca de frame, help plz, qq eu faço ? já ta em 640, coloquei o R_useNv30 1, mas nada sempre na mesma lentidão.

    o D3 que eu tenho aqui, tem 1 patch pra funcionar o menu, mas tentei pelo map e3/e3_1 e deu mesma merda...

    Det 43.51, instalei ele (tinha um mais novinho antes) e nada tambem..

+ Responder Tópico Ir para o Fórum
Página 1 de 2 1 2 Última

Assuntos do tópico

Compartilhar

Permissões