+ Responder Tópico
  1. #1
    Membro
    Info
    Registro
    Feb 2002
    Mensagens
    256
    Verdinhas
    0

    Rodando o UT no Linux

    ae pessual, alguem pode me ajudar a configurar minha placa 3d (Geforce 2 Mx 200) no linux, o ut eu sei instalar, so falta instalar a placa msm.. ja tentei de tudo e nao consegui, quem puder me ajudar vlw ai..

  2. # Publicidade
    Publicidade

  3. #2
    Membro
    Info
    Registro
    Apr 2001
    Mensagens
    3.554
    Verdinhas
    12

    no HardWhat acho q fica mais facil o povo ajudar

  4. #3
    Membro
    Info
    Registro
    Feb 2000
    Mensagens
    762
    Verdinhas
    5

    Na página da nvidia ensina como instala, é só procurar na página de drivers pra Linux. Se for Red Hat ou Mandrake é mais fácil, é só instalar os rpms. Se não for daí já é um pouco mais complicado.

  5. #4
    Membro
    Autor do tópico
    Info
    Registro
    Feb 2002
    Mensagens
    256
    Verdinhas
    0

    putz q saco, ja tentei de tudo q tem la, mas nao ta dando.. so da pau essa porra de linux...

  6. #5
    Membro
    Info
    Registro
    May 2001
    Mensagens
    534
    Verdinhas
    0

    porra só se vc usa conectiva, uehueheuhehe...
    pow, mas tem driver lá no site da nvidia tudo direitinho. é só botar e rodar.

  7. #6
    Membro
    Info
    Registro
    Mar 2002
    Mensagens
    634
    Verdinhas
    2

    Quando alguém conseguir rodar me avisa. Eu e o KerberuZ tentamos instalar no conectiva, red hat e mandrake. Fizemos os procedimentos indicados no site da nvidia mas mesmo assim não funcionou corretamente.Ativamos a aceleracao 3d mas ficava quadro a quadro.

  8. #7
    Membro Avatar de DiaboluZ
    Info
    Registro
    Sep 2000
    Mensagens
    46
    Verdinhas
    0

    Se vcs falarem os erros que tão dando fica mais fácil

    O que mais dava errado pra mim é que os rpms da Nvidia nunca batiam com a versão do distro/kernel. Ai só vai com o rpm do src.

  9. #8
    Membro
    Autor do tópico
    Info
    Registro
    Feb 2002
    Mensagens
    256
    Verdinhas
    0

    pow, valeu pela dica, meu mandrake eh o 9, como nao tinha na pagina da NV pro mandrake 9 eu peguei pro 8.2 msm, ai eu isntalei, editei o XF56Config-4, reiniciei, e bummmm! o linux nao entrava no modo grafico, tive q formatar reinstalar ele todo, ae 2ª tentativa: peguei os source em formato .tar, ae qnd fui dar make install deu um pau, ae eu digitei make install -i (pra ignorar os erros), reiniciei e aconteceu mema coisa, to indo agora pra minha 3ª tentativa q eh oq vc falou...

  10. #9
    Membro Avatar de DiaboluZ
    Info
    Registro
    Sep 2000
    Mensagens
    46
    Verdinhas
    0

    Num precisava reintalar naum, era só voltar
    o XF86Config-4 pro driver nv, ao invés do nvidia, usando o vi, no modo texto mesmo. De qualquer modo é sempre bom ter opção no boot para entrar em modo texto.

    Aki sempre instalei assim:

    arquivos:
    NVIDIA_GLX-1.0-3123.i386.rpm
    NVIDIA_kernel-1.0-3123.src.rpm

    rpm --rebuild NVIDIA_kernel-1.0-3123.src.rpm
    rpm -ivh /usr/src....NVIDIA_kernel-1.0-3123.(linha que aparece com "wrote")

    rpm -ivh NVIDIA_GLX-1.0-3123.i386.rpm

    dai é só editar o XF86Config-4 colocar o nvidia, tirar o load dri,etc..

  11. #10
    Membro Avatar de TeMpEsT
    Info
    Registro
    Mar 2001
    Mensagens
    838
    Verdinhas
    0

    ae
    eu tinha o mandrake 8.2 e rodei perfeitamente em openGL em 32Bits

    tanto com minha ex-geforce2 MX400 e agora rodo na minha GF3 [email protected]

    Se precisar eu explico com mais calma pelo icq...

    (UiN:1518174)

  12. #11
    Membro
    Autor do tópico
    Info
    Registro
    Feb 2002
    Mensagens
    256
    Verdinhas
    0

    blz pessoal, ja cosnegui ja, usei o src.rpm do kernel, e o rpm do glx...

  13. #12
    Membro Avatar de Mozart
    Info
    Registro
    Nov 2001
    Mensagens
    365
    Verdinhas
    0

    Linux ? o q é isso?

  14. #13
    Membro
    Autor do tópico
    Info
    Registro
    Feb 2002
    Mensagens
    256
    Verdinhas
    0

    eu axo q eh de comer...

  15. #14
    iad
    iad está offline
    Membro
    Info
    Registro
    Apr 2001
    Mensagens
    373
    Verdinhas
    0

    Originalmente enviada por DiaboluZ
    Num precisava reintalar naum, era só voltar
    o XF86Config-4 pro driver nv, ao invés do nvidia, usando o vi, no modo texto mesmo. De qualquer modo é sempre bom ter opção no boot para entrar em modo texto.

    Aki sempre instalei assim:

    arquivos:
    NVIDIA_GLX-1.0-3123.i386.rpm
    NVIDIA_kernel-1.0-3123.src.rpm

    rpm --rebuild NVIDIA_kernel-1.0-3123.src.rpm
    rpm -ivh /usr/src....NVIDIA_kernel-1.0-3123.(linha que aparece com "wrote")

    rpm -ivh NVIDIA_GLX-1.0-3123.i386.rpm

    dai é só editar o XF86Config-4 colocar o nvidia, tirar o load dri,etc..


    cara ja fiz de tudo , mas aqui nao vai conectiva 8

    quando do o comando pra instalar o kernel ele da 100% e nao instala

  16. #15
    Membro Avatar de DiaboluZ
    Info
    Registro
    Sep 2000
    Mensagens
    46
    Verdinhas
    0

    Hmmm, já rodei o ut com o cunectiva 6 e rodava bele, mas não lembro se tive que instalar algo além da instalação padrão, pq sempre recompilava os kernels.

    Tipo chute, tenta instalar os kernel-headers.rpms se ainda não tiverem instalados. Ah e desinstala esses rpms que não carregaram o driver antes, que tambem pode dar pau.

    Se não der certo tenta o redhat 8 mesmo, que instalei de primeira ontem esses drivers e o ut2 (isso após eu brigar 1 semana com esse cunectiva e o mantrake novo que deram pau direto na instalação no meu micro)

  17. #16
    Membro
    Info
    Registro
    Feb 2001
    Mensagens
    266
    Verdinhas
    2

    DiaboluZ?!?!?!

    Vc existe ainda?

  18. #17
    Membro
    Info
    Registro
    Feb 2002
    Mensagens
    4.040
    Verdinhas
    2

    Anota meu icq (tá na assinatura). Vc tem o kernel headers e seu kernel-source instalados?

  19. #18
    Membro Avatar de DiaboluZ
    Info
    Registro
    Sep 2000
    Mensagens
    46
    Verdinhas
    0

    Originalmente enviada por foguinho
    DiaboluZ?!?!?!

    Vc existe ainda?
    olha quem fala, hehe
    to largado pq meu adsl tá podre

  20. #19
    Membro
    Info
    Registro
    Oct 2002
    Mensagens
    16
    Verdinhas
    0

    Ae... LINUX r0x!!!

    ae manus... UT + UT2K3 em Linux.. melhor coisa pa joga online cara... uso SLACKWARE 8.1 (levinho)...

    Qualquer outra duvida de como fazer funfar, UIN ae do ICQ no assign.. blz ???

    é nois... MATOMEMO via LINUX!!!

  21. #20
    Membro
    Info
    Registro
    Feb 2002
    Mensagens
    4.040
    Verdinhas
    2

    mastigado

    É melhor pra jogar online sim (conexão BEM mais estável), mas precisa de hardware mais poderoso, se o caso for jogar em openGL. Se a máquina roda já no limite do aceitavel no windows, não tentem o linux pra jogar, a não ser que tenham uma 3dfx e usem glide como render device.

    O Conectiva 8 vai dar erro de licensa GPL compilando o nvidia-kernel. Pra facilitar as coisas pra quem quer tentar o linux, NÃO usem distribuições que acabaram de sair do forno (Mandrake9, Conectiva 8 e RedHat 8). Usem alguma distribuição que já tenha kernel+GLX localizados pra ela, tipo Mandrake 8.x, RedHat 7.x, facilita muito a vida pra quem não quer apanhar do OS.

    Toscamente, vou deixar aki um how-to meia-boca, pra quem quer instalar o UT+NVidia no Linux:

    - Instale o Linux

    -No dir RPMS da sua distribuição (se for MDK, Conectiva ou RH), instale o kernel-headers, o kernel-source e o binutils (com rpm -Uvh nomedarpm)

    - Baixe um aplicativo chamado NVchooser e rode ele com sh NVchooser.sh, e anote o nome dos arquivos que vc deverá baixar (kernel e GLX)

    - Baixe os arquivos listados pelo NVchooser, e se forem RPM, instale normalmente com rpm -i ou rpm -Uvh. Se forem listados tar.gz ao invés de RPM, tem que compilar. Use tar -xzvf nomedofile.tar.gz. Ele vai criar um diretorio com o nome do arquivo tar. Entre no dir e digite MAKE INSTALL.

    se correu tudo bem, sem erros, precisa editar o arquivo XFree86-4, que fica dentro da pasta etc/X11. Faça um backup dele antes de editar.

    - Procure na seção modules o nome do driver (normalmente algo como Driver "vesa" ou Driver "nv") e altere para Driver "nvidia"

    Tombe o X e entre de novo (startx). Se tudo deu certo, aparecerá uma "splash screen" com o logo da Nvidia.

    Se não deu certo, é pq vc se esqueceu do kernel headers, do binutils ou do kernel-source instalados, ou ainda pq está usando uma distribuicao nao-gpl.

    Espero que isso ajude.

+ Responder Tópico Ir para o Fórum

Assuntos do tópico

Compartilhar

Permissões